Jump to content
Sign in to follow this  
bicsintegra

blowing hot air

Recommended Posts

my wife's 2013 edge sport only blows cold air on the passenger side, the driver side is hot like the heat is on.  it has the dual climate zone controls, has anyone else had this issue?

Share this post


Link to post
Share on other sites

Yes, it's happened to me twice on my 2013 Edge Limited - except it was the opposite - I had AC on the drivers side and heat on the passenger side of the centre vents.  Good news - there's an easy fix that I found when I googled the issue - and I used it both times and it fixed it both times - best part is that the fix costs nothing.   With the car in park, press the POWER and DEFROST buttons at the same time on the main console.   Hold them down for about 3-5 seconds.   Then press POWER again and see if the cool air flows on both sides of the vent.    Let me know if it works.   Saved me a trip to the dealership both times and cost me zero to fix.  #winning

Share this post


Link to post
Share on other sites
On 7/13/2019 at 4:16 PM, pc2013edge said:

Yes, it's happened to me twice on my 2013 Edge Limited - except it was the opposite - I had AC on the drivers side and heat on the passenger side of the centre vents.  Good news - there's an easy fix that I found when I googled the issue - and I used it both times and it fixed it both times - best part is that the fix costs nothing.   With the car in park, press the POWER and DEFROST buttons at the same time on the main console.   Hold them down for about 3-5 seconds.   Then press POWER again and see if the cool air flows on both sides of the vent.    Let me know if it works.   Saved me a trip to the dealership both times and cost me zero to fix.  #winning

What was the point of doing this? What role did it play in getting the AC to work as needed?

Share this post


Link to post
Share on other sites

I know this question was asked over a year ago, but for the sake of possibly helping someone else out in the future, the procedure that was mentioned about holding the defrost/power button for 5 seconds and then pressing the power button is some sort of AC reset/recalibration.  When you do that, you will hear the small motors (blend door actuators) reset and run through a full sweep.  It will then move the air across all vents in order and once done, it usually re-aligns the blend door actuator in question.  

This is a temp fix though.  It will get you through that one issue, but will come back.  Eventually you will want to replace the affected actuator.  The passenger side one is behind the glove box, the driver side one is up under the dash/center stack.  Each part is roughly $50 if applicable.  

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×