Jump to content
Ford Edge Forum
Sign in to follow this  
Ronald S Katz

2015 needs engine

Recommended Posts

My 2015 Edge SE fwd 2.0 EB with 150k is needing an engine.  Began with a misfire on cylinder 1.  White Smoke on startup. And, sweet smell of coolant.  Local dealer checked it out. Pressure tested the coolant system and found it leaking into the #1 combustion chamber.  $6100 to replace the long block. Never ever had any issues with the Edge before this.  Love the vehicle.     Perfect size, power, handling, ride. The Escape forums note there is a TSB on this for the 2.0 EB used in the 15-18 escape, edge, fusion and a few Lincolns. Is says it is due to corrosion. Always followed Maintanence schedule.  Always at local dealer.  Very very disappointed.  Used to be a Toyota guy. But, decided to go AMERICAN (I know it is built in Canada).   Made the switch to fords a few years ago. Wife has a 16 explorer sport, we have an old F150 for doing things around the house. Her explorer is a little scary with the things we are finding. Funny, our 165k mile 2006 F150 4.6 4x4 is our most reliable vehicle. Hopefully, if you get the corrosion caused misfire your still in warranty. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×