Jump to content
Ford Edge Forum
lesun90

ford edge 2015 Titanium touch screen problem (need calibration)

Recommended Posts

Hi,

I recently had a problem with the touch screen on my 2015 ford edge (titanium rim).

The touch screen does not register my touch correctly. It happens a few times in the past and I just go to the bezel diagnostic (by hold tune next + cd eject button) to re-calibrate the touch screen. Normally, the error is small, so I still managed to touch the right place to access the right menu.

However, this time, the problem becomes worst.  The touch screen still working, but the error is huge, there is no way I could touch the calibrate menu.

Is there any way to choose an option in the bezel diagnostic without touch it?

Or any recommend solution is really appreciated.

 

Thank you.

Share this post


Link to post
Share on other sites

press and hold the CD eject button and then SEEK UP at same time for about 5-10 seconds. This will put the unit into diagnostics mode and it does a speaker test. After the speaker test is complete a menu will show up. Now press and hold the seek down button until the calibration screen appears. After following the instructions for calibration, press anywhere on the screen to exit. It is now calibrated properly and you may exit back to the main screen.

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites

This should be stickied!

 

Share this post


Link to post
Share on other sites

Those instructions are for MFT/MLT/SYNC2 by the way.

  • Thanks 1

Share this post


Link to post
Share on other sites
20 hours ago, jmr061 said:

press and hold the CD eject button and then SEEK UP at same time for about 5-10 seconds. This will put the unit into diagnostics mode and it does a speaker test. After the speaker test is complete a menu will show up. Now press and hold the seek down button until the calibration screen appears. After following the instructions for calibration, press anywhere on the screen to exit. It is now calibrated properly and you may exit back to the main screen.

 

I could not say thank enough for your post. This issue had been bugging me for a week and I already think of replacing the whole module. You save me a lot of trouble and money.

 

All the bests.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×