Jump to content
Ford Edge Forum
Froggy372

Engine noise

Recommended Posts

Hello, so my water pump started leaking outside the engine so I replaced it and the timing chain. Drove it for 2 months and one day it stalled while driving down the road. I did some research which led me to replacing the throttle body. I drove the car for 2 weeks with no issue. My son took the car and 30 minutes after he left, called me saying the car stalled and when he started it back up it was making a noise. So I hear a knocking noise coming from the back bank but cant tell if it's a connecting rod bearing, wrist bearing or hopefully just a loose rocker arm. It doesnt knock immediately but as I raise the rpms its gets louder but when I let it sit for a few days and restart it the noise is gone at first then starts coming back. It's not an obnoxious noise like a broken connecting rod. Any help in what direction to take here would be greatly appreciated.

Share this post


Link to post
Share on other sites

Year and mileage?  Are you sure timing is not a tooth off? Did you replace the VCT solenoids also?  Might need the phasers if the TSB applies.

TSB 11-6-1_3.5L-3.7L ENGINE - VCT CODES P0011, P0012, P0016, P0018, P0021, P0022 - RUNS ROUGH OR MISSES - VEHICLES BUILT ON OR BEFORE 20081215.pdf

Edited by WWWPerfA_ZN0W

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×