Jump to content
19EdgeSTeve

Livernois turbo jitter

Recommended Posts

Tune works great for accelerating from a stop and great with city driving. 

Having an issue with highway driving. Medium acceleration from 40mph-60mph and 60-80 and i can see and the feel the tubo boost jitter. Very very sloppy and i dont like the way it feels. At all. 

 

Livernois hasnt heard of this and asked me to check connections and codes. Nothing there...

 

Anyone else have this issue before? Im definately going to reload stock tune and check if the same prob persists. 

Share this post


Link to post
Share on other sites

does it feel like a subtle surge....very minor but still can be felt slightly?

Share this post


Link to post
Share on other sites
1 hour ago, cds71 said:

does it feel like a subtle surge....very minor but still can be felt slightly?

 

Not a surge per se.  It's almost like the car is waiting for me to floor it and can't maintain steady boost, or like the turbos aren't boosting at the same PSI.  The boost needle will literally jitter. you can feel it in the car to.  

Share this post


Link to post
Share on other sites

Yup .....Ive felt that before!  Not sure what it is, but I learned to just live with it.  I found it to almost go away in drive mode.   It seems to be more frequent in sport mode.

Edited by cds71

Share this post


Link to post
Share on other sites

Honestly never felt it on mine.  I tend to not drive gently though and would be accelerating quite hard. 

Share this post


Link to post
Share on other sites

I have not experienced this.  But I’m only running the 91 tune (but still using 93 Shell gas) so not sure how differently they do the boost on 93.  Yesterday was a beautiful day and I was heading back from a trip, the interstate was very sparse, and I had a few opportunities to do 80-120 runs.  They were effortless and smooth, no jitter.  The car feels very confident and sure at that speed, it’s a great feeling!

Share this post


Link to post
Share on other sites
3 hours ago, jamie1073 said:

Honestly never felt it on mine.  I tend to not drive gently though and would be accelerating quite hard. 

 

It's not a gentle acceleration.  somewhere between full throttle and light acceleration.  And it didn't do at all yesterday.  Re loading the stock tune this weekend to check it out.

Share this post


Link to post
Share on other sites
19 hours ago, 19EdgeSTeve said:

 

It's not a gentle acceleration.  somewhere between full throttle and light acceleration.  And it didn't do at all yesterday.  Re loading the stock tune this weekend to check it out.

 

I sometimes drive normal and still really never feel it anywhere in the rev band.  I do on occasion get a hard start though, meaning cranking for more than 6-10 seconds.  But that is about it from the tune.  I do need to go back to stock to see if that is an engine issue or just the tune. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×