Jump to content
Snoking

New 2020 EDGE ST

Recommended Posts

DW's 2004 Buick Rainier 5.3 V8 with 70k on the clock got T-Boned Saturday, so we went test driving cars Sunday and one was a 2015 Sport, and there was no turning back. Yesterday we drove home a new 2020 ST with 1500 miles as a dealer loaner. It was discounted 9500 bucks. 

Edge ST.jpg

Edited by Snoking
  • Like 3

Share this post


Link to post
Share on other sites

Congrats

Share this post


Link to post
Share on other sites

I really like driving the new Edge ST. 

 

A little comparison between a 1967 Camaro SS 350 I had.

 

The internet says this about my old 67 SS/RS 350 Camaro:
0 to 60 mph in 8.0 sec, with the quarter mile coming up in 15.4 sec at 90 mph.

2020 Edge ST:
0 to 60 mph in 5.7 sec and the quarter mile time is 14.3 and 98 MPH

 

Camaro weighed around 3300 pounds and the Edge 4500. 

And the Edge would run away and hide from the old Camaro in the twisties. I drove that Camaro a lot on Highway 1 on the Northern California Coast while stationed at Point Arena, Ca Loran A station there. Best to drive that road North bound if one has a DW riding shotgun. It is a bit like Pikes Peak, "real women do not need guard rails"! My DW said BS.

Share this post


Link to post
Share on other sites

Can we talk head lights? Tonight we did our first really night time driving. High beams work good, auto mode works OK, do not like them switching to low beam when you slow below about 30 MPH, low beams work ok on a level road. Get on a rolling road with lots of ups and downs and the cutoff line stinks. Our RAM truck does the same thing, however I found running the fogs all the time fills in above the cutoff line without getting flashed a lot. The Edges fogs shine down and out. Can they be adjusted to the point of filling in about the cutoff line of the low beams. We drove about two hundred miles today, and lie-o-meter is reading 26.4 MPG. 

Share this post


Link to post
Share on other sites

Anyone else with a ST in Ford Performance Blue notice the the plastic rear corners do not quite match the rest of the body color?

Share this post


Link to post
Share on other sites

They get painted at different times and the paint reacts different to plastic than metal. Can be seen on almost any car

6A704760-B593-40E7-AE7C-7632F232124A.jpeg

  • Like 2

Share this post


Link to post
Share on other sites
13 hours ago, Snoking said:

Anyone else with a ST in Ford Performance Blue notice the the plastic rear corners do not quite match the rest of the body color?

I'll second what @Nick Halstead said and add that there is a tolerance for the amount of color the hang on parts are allowed to be "off". Without seeing it in person it would be almost impossible to tell, pictures rarely ever capture the discrepancy correctly.

Edited by dolsen

Share this post


Link to post
Share on other sites

My white ST doesn't match either.  Not to noticeable until looked at close up. 

Share this post


Link to post
Share on other sites

Played around with music on an USB thumb dive today. I wantws to use two USB thumb drives with difference styles music on one USB port and the smart phone plugged in for nav on the other.  I ordered a cheap USB hub adapter and the Edge barfed on it, saying that is does not support USB hubs, please remove. So I played around with more music on the USB thumb drive that I had been using with all the music files in the root of the directory. I now have three folders with different styles of music. It will at the last song of a folder start playing the next song in the next folder. Or I can push browse and choose a song from one of the other folders and it will start playing those in order. So I am happier, and now working on training DF on how she can manage the music.

 

As a side note, I really like driving the Edge ST! May buy a second one for Arizona or fine a clean Sport for down there when we arrive this fall. 

Share this post


Link to post
Share on other sites
4 hours ago, Snoking said:

Played around with music on an USB thumb dive today. I wantws to use two USB thumb drives with difference styles music on one USB port and the smart phone plugged in for nav on the other.  I ordered a cheap USB hub adapter and the Edge barfed on it, saying that is does not support USB hubs, please remove. So I played around with more music on the USB thumb drive that I had been using with all the music files in the root of the directory. I now have three folders with different styles of music. It will at the last song of a folder start playing the next song in the next folder. Or I can push browse and choose a song from one of the other folders and it will start playing those in order. So I am happier, and now working on training DF on how she can manage the music.

 

As a side note, I really like driving the Edge ST! May buy a second one for Arizona or fine a clean Sport for down there when we arrive this fall. 

Why not store the music on your Phone? You can use the phone for maps and play music simultaneously. That's what android auto and car play are for.

Very easy to set up multiple playlists on your phone.

  • Like 2

Share this post


Link to post
Share on other sites

I would have to do that twice! His and hers. 

Share this post


Link to post
Share on other sites
3 hours ago, Snoking said:

I would have to do that twice! His and hers. 

 

That's also an easy thing to do. And the phone has now become a personal music player. She will now never be without her music because who goes anywhere without their phone these days?

Share this post


Link to post
Share on other sites
16 minutes ago, handfiler said:

 

That's also an easy thing to do. And the phone has now become a personal music player. She will now never be without her music because who goes anywhere without their phone these days?

At our age we forget them once in a while! We tend to buy cheaper lower GB memory phones, and photo's use up a lot of it. And we are not trading the the latest a greatest new phone every 6 months or year like some do. A 8.95 USB drive holds enough music for us.

 

Then there is this: Bluetooth compresses music in a lossy manner and limits the bandwidth as well to below 15 kHz.

Edited by Snoking

Share this post


Link to post
Share on other sites
4 hours ago, Snoking said:

At our age we forget them once in a while! We tend to buy cheaper lower GB memory phones, and photo's use up a lot of it. And we are not trading the the latest a greatest new phone every 6 months or year like some do. A 8.95 USB drive holds enough music for us.

 

Then there is this: Bluetooth compresses music in a lossy manner and limits the bandwidth as well to below 15 kHz.

Android Auto and CarPlay only work with the data cable plugged in to the USB port so no Bluetooth involved. My files have all been converted at 44.1Khz/16bit (FLAC format).

Anyhow I realize your not interested in what I have to say and I fully understand your point of view. Technology is not for everyone.

Share this post


Link to post
Share on other sites
43 minutes ago, handfiler said:

Technology is not for everyone.

That is pretty funny given my 150+ weeks of technical training 8 hours a day, 5 days a week in electronics, computer equipment and networking, along with 42 years working experience in those fields. FWIW I can listen to my music without removing my phone from it's belt carrier via the USB drive inserted into one of the two USB ports.. Just like your phone I can carry the USB drive to my computer and manage the music on it.

 

Speaking of technology, the 2020 Edge is way behind my 2015 RAM in many ways:

RAM remembers seat, steering wheel, mirror, heat, music settings etc by driver base on the FOB used to open the door. EDGE push a button to get a sub set of those things changed per driver.

 

RAM's EVIC is much more tailorable vs the Edge's. The uconnect 8.4 display is much easier to navigate vs the Sync display in the Edge.

Edited by Snoking

Share this post


Link to post
Share on other sites

So 2019s and 2020s got Sync updates yesterday OTA. People with 2019's are not liking the new default theme(the one that was default on the 2020s. Anyone know what changed on the 2020s?

Share this post


Link to post
Share on other sites

So I put our screen in Night and then went to display settings and changed it from the blight blue to a one of the three other choices(the far right one). We are liking this!

Chris

IMG_20200906_131440.jpg

Share this post


Link to post
Share on other sites

Mine is set the same but I do miss the black out prior to the update, but I can forgive it for the better layout and responsiveness.

Share this post


Link to post
Share on other sites

I had the June 2nd transmission TSB done yesterday and DW drove it home. So today I took it for a spin. Transmission is now the way it should have been. I asked before delivery to have it done on June 22nd and they said you have to complain about something before they would do it. So yesterday for an oil and filter change to be ready to store it for the winter while we are in Az. So I complained about funky shifts and harsh engagements, and the paper work shows this time they did the upgrade. Big improvement.  

 

Share this post


Link to post
Share on other sites

So, another thing. If I build a 2020 with 400A package, it now shows that it would have have NAV and ours does not?

Voice-Activated Touchscreen Navigation System with Pinch-to-Zoom Capability, SiriusXM Traffic and Travel Link

Edited by Snoking

Share this post


Link to post
Share on other sites

Are you sure that you did not  misinterpret the build selection options?  I just went through the build exercise for a 2020 Edge ST and the option that you referred to appears to be  part of  the 401A equipment group.  The 400A equipment group is the standard equipment group. The way i interpret it,  400A does not have the adaptive cruise control either.  

 

14 hours ago, Snoking said:

So, another thing. If I build a 2020 with 400A package, it now shows that it would have have NAV and ours does not?

Voice-Activated Touchscreen Navigation System with Pinch-to-Zoom Capability, SiriusXM Traffic and Travel Link

 

Share this post


Link to post
Share on other sites

Here are two pictures of the build process with only 400A and NOT 401A. $43,700 price. Could be an error with Ford's build process. I have an email out to my sale rep. Chris

Nav Option.jpg

Nav Option 2.jpg

Share this post


Link to post
Share on other sites

According to the order guide it’s not included with the base 400a pkg and when I do build and price it shows it as part of the 401a package.

 

 

72A3C50B-F7D8-4C3A-BB78-7D8CB13168DD.png

EBCAF059-271D-42CA-9080-3BCFE13E02F3.jpeg

Share this post


Link to post
Share on other sites

It appears that it is added to 400A by $795 Ford Co-Pilot360 Assist+™ 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×