Jump to content

Recommended Posts

Hello all, pics attached. I recently within the last few weeks upgraded from a 2013 Ford Edge Sport to its newer twin version, a 2016 Ford Edge Sport with the Ford Premium Care warranty. I've noticed my rear lightbar isn't working. I took it to the dealer and adressed my concerns. They took my vin and came back with your Vin is showing that the vehicle isn't programmed for the lightbar to work and is a reflector only.

From my understanding the lightbar was standard to work on the Titanium/Sport models, not an option. I let the dealer know I was not satisfied with their answer and they now have it scheduled to actually take it apart and diagnose it.  Am I correct in my concerns that the light bar should be working on my Sport model Edge? I spoke with Ford chat who also took my Vin and told me that my vehicle is showing led tail lights and lightbar. 

 

Also and if I would have noticed but (I had tunnel vision) it would have been a game changer for this particular Edge. It doesn't have BLIS....but it does have the heated, auto and memory mirrors. I am hoping since it is a Sport that it is possibly already wired for the BLIS mirrors and modules in the rear and with Forscan it could be a quick switch over. Anyone have any experience adding Bind Spot?

20200628_191141.jpg

20200606_195417.jpg

  • Confused 1

Share this post


Link to post
Share on other sites

You are right, the light bar was standard on Titanium and Sport models and it should light up on yours.;)

 

Claude.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Awesome, Thank You! I am just worried the dealership is going to come back with the same answer and say the part number comes back as a reflector only after diagnostic. 

They told me my Premium Care Warranty wouldn't cover it and it would be $1900 to replace since it would be an add on and didnt come factory. I did just buy it so I havent actually seen it working to argue the case other than I know it should be working and that it came standard on all Sports. 

I did take the rear interior panels off and the lightbar out (looks exactly like the pic) there are 3 plugs running out from it and I saw like 6 different part numbers, some ending in A's some B's so I'm not even sure myself if it is correct. I just want it to work and at this point I'm really missing my 13

 

20200628_232739.jpg

Edited by Gr8Wte
  • Like 1

Share this post


Link to post
Share on other sites

I know that it is impossible for an employee to know every single feature of every single car on the lot but that's ridiculous. The easiest thing for them to do is to check a different Titanium or Sport!  Not sure how/ what they checked and did not find the correct info.  The only reason why I would deal with that dealership is unless I purchased the vehicle there and I would try to put the onus on them as you are doing. If they can't sort out such an obvious mistake I'd suggest going to a different dealership.

 

Perhaps you can use that as grounds for them to unwind the deal and refund you.  That way you can find a sport with all the features you want least of all a working taillight!

FYI your extended warranty can cover the taillight, you would have to add that feature to your warranty.

 

 

Edited by onyxbfly
  • Like 1

Share this post


Link to post
Share on other sites

The Ford dealership I purchased it from is 2 hours away, this is my nearest local Ford Dealership but I think you're right... that I should probably go elsewhere. 

 

If it wasn't so far away I probably would. If they find that it should be working its definitely covered, Its the first thing listed under electrical 

Screenshot_20200622-193010_Drive.jpg

Edited by Gr8Wte
Photo
  • Like 1

Share this post


Link to post
Share on other sites

Just as @onyxbfly stated, the Titanium & Sport models had the light bar working as standard. It's not just the light bar that is different, even the side taillights are different. The light-bar's illumination actually continues the light pattern from the taillights' surround. The SE/SEL's taillights illuminate differently, only the inside portion lights up. On major difference and easily identifiable is the rear turn signals, SE/SEL's flash red and are the same as the brake light. Titanium/Sport have amber rear turn signals separate from the brake lights. I posted some photos here trying to show the differences.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Thanks I definitely have a Sport so I don't even know why I'm having to deal with this, my luck for some reason I would have the SE/SEL lights. I'll check the color of the turn signal lights out after work. I do know the tail light surrounds are always on with the parking lights. Are these light bar lights knows to go out? I'm right at 34,xxx miles. 

 

Edit: turn signals are amber and light up exactly as the Sport ones should so it seems I just have a non working light bar. 

Edited by Gr8Wte

Share this post


Link to post
Share on other sites
1 hour ago, Gr8Wte said:

Are these light bar lights knows to go out? I'm right at 34,xxx miles. 

 

Anything can fail. I remember reading maybe 1 or 2 members with a failed light bar and I think even one who actually had an SE/SEL bar fitted from the factory to his Sport or Titanium but replaced under warranty. You have two issues:

  1. Your dealer. unfortunately, most are like that, whatever you report off they immediately answer that it is "Normal". If you find a dealer that really listens to you, then become friends with them, they are a gem.
  2. You purchased your Edge used. Maybe the previous owner replaced the original light-bar and for some reason (intentionally or not) got an SE/SEL bar installed. Reports of high level moisture going into the rear taillights/bar, were not uncommon, so might have been (mis)replaced due to that. Still, having the premium warranty, I guess it should still be covered.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×