Jump to content
Obeidat87

Cooling fans running all time with AC

Recommended Posts

Hello everyone .. I am new here and hope to find an answer for my problem.

 

I have 2014 ford edge limited 3.5 ,, since 2 months i noticed when i turn on the AC both radiator cooling fans starts running at the highest speed with a very loud sound (I can feel the vibration and hear the sound while setting inside the car at idle) and never stop until i turn the AC off it will back to low speed with cycling .. my question is it normal to run at the highest speed all the time without cycling ? If no what could be the problem?


Thanks in advance

Edited by Obeidat87

Share this post


Link to post
Share on other sites

the driver side fan should not run with a/c completely off.

 

if both fans are running all the time, install a new fan assembly.  most times it is the fan motors at fault, but there is a sprinkling of FCM failures also.  Motorcraft is the best option.

 

 

Share this post


Link to post
Share on other sites

Where are you located? 

In the Middle East, the Edge will have its fans run on full speed if the A/C is on and the outside temperature is higher than a certain limit. I think it was 32 or 34 C. Or thereabouts.

Share this post


Link to post
Share on other sites
On 8/4/2020 at 1:48 AM, WWWPerfA_ZN0W said:

the driver side fan should not run with a/c completely off.

 

if both fans are running all the time, install a new fan assembly.  most times it is the fan motors at fault, but there is a sprinkling of FCM failures also.  Motorcraft is the best option.

 

 

It run all the time only when the AC is on .. when i turn it off the the fan slowing down the speed.

Share this post


Link to post
Share on other sites
18 hours ago, omar302 said:

Where are you located? 

In the Middle East, the Edge will have its fans run on full speed if the A/C is on and the outside temperature is higher than a certain limit. I think it was 32 or 34 C. Or thereabouts.

Yes Mr Omar I am in the Middle East / Saudi Arabia and the avarage temprature those days around 40 to 45 C. But my problem is even when i turn the AC at early morning or eveing (when the car is cold) after starting the car immediately the fans start running on the highest speed. 

 

Share this post


Link to post
Share on other sites
4 hours ago, Obeidat87 said:

Yes Mr Omar I am in the Middle East / Saudi Arabia and the avarage temprature those days around 40 to 45 C. But my problem is even when i turn the AC at early morning or eveing (when the car is cold) after starting the car immediately the fans start running on the highest speed. 

 

 

Yes, I am in Qatar so I know the summer heat. It is normal for the 2011 to 2014 to be like that. Even in the morning it is above 32 C, right? I had a 2011 MKX (similar to the Edge) and it was like that. Take your Edge for a car wash were the outside temperature reading will become lower than 30 for a while after the wash and you'll hear fans turning at lower speeds.

  • Like 1

Share this post


Link to post
Share on other sites
11 hours ago, Obeidat87 said:

Yes Mr Omar I am in the Middle East / Saudi Arabia and the avarage temprature those days around 40 to 45 C. But my problem is even when i turn the AC at early morning or eveing (when the car is cold) after starting the car immediately the fans start running on the highest speed. 

 

 

Welcome.

 

Please consider adding your location and Model/Year to your profile signature - https://www.fordedgeforum.com/settings/signature/

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×