Jump to content
C300

New 2020 Edge ST owners

Recommended Posts

After driving an assortment of vehicles we drove a used 2019 ST. Really liked it.  For $3k more bought a new 2020 ST. Was on show room floor. Had a vibration when I  test drove it. 15 miles on it. They said it was flat spots on tires from sitting (right...). After putting some mileage on it vibrations getting worse. More pronounced under part throttle going up slight incline 55-65 mph. Transmission is slipping between 2-3 and in/out of 6th. Also wouldn't stop in parking lot sometimes. Like forgeting to push in clutch pedal and trying to stop w/manual trans. After it spent most time in shop brought to different dealership. They diagnosed and changed the transmission. Quoted $12,000 for new one ! Warranty of course. Still slipping between 2-3. Actually worse! Not sure if this is the correct place to post. But anyone else have issues? 

We bought the ST and from the little time we got to drive it we liked it. That said maybe we did get a lemon?!?! Any info would be appreciated 

Share this post


Link to post
Share on other sites

Depending on when I was built, make sure it has had the transmission software update.

 

TECHNICAL SERVICE BULLETIN
8F57 Transmission - Harsh Engagements And/Or Harsh Upshift/Downshift

20-2190 02 June 2020
This bulletin supersedes 19-2313. Reason for update: Incorrect or Incomplete Symptom
Model:
Ford 2019-2020 Edge Transmission/Transaxle: (8F57)
Lincoln 2019-2020 Nautilus Transmission/Transaxle: (8F57)

 

This fixed a lot of transmission issues.

Edited by Snoking

Share this post


Link to post
Share on other sites
8 hours ago, C300 said:

Had a vibration when I  test drove it. 15 miles on it. They said it was flat spots on tires from sitting (right...). After putting some mileage on it vibrations getting worse. More pronounced under part throttle going up slight incline 55-65 mph.

You didn't mention whether it's FWD or AWD. If AWD I'd suspect the drive shaft. If FWD the CV joints. 

 

This site has a good explanation:

https://www.yourmechanic.com/services/car-vibrates-going-uphill-inspection

Edited by enigma-2

Share this post


Link to post
Share on other sites
40 minutes ago, handfiler said:

Aren't all Edge ST's AWD?

Yes, missed that. Thanks.

 

 

Edited by enigma-2

Share this post


Link to post
Share on other sites

Yes, ST is only AWD. FWD biased. I originally thought it was the PTU or a drive shaft. Something in the driveline. But then the tranny slips too. Then wouldn't stop and was shaking violently until shut off. Like the torque converter locked up and wouldn't let go. Maybe it was built on co-vid Monday and has multiple problems. Just wonder if anyone else has had any of these issues. 

Share this post


Link to post
Share on other sites

I have not on mine, but, then again, I only have 1855 miles on mine (purchased in Jan 2021). 

 

Side question: how can one tell when:

1. the transmission is slipping?

2. if the engine is skipping gears?

 

Thanks 

Share this post


Link to post
Share on other sites

Most likely the transmission would overheat and the fluid will be opaque and foul smelling. 

 

I believe that a bad torque converter can cause the transmission to drop out of gear. Not to mention being shuttering, clunking or noisy.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×