Jump to content

Recommended Posts

Has anyone done the VISKOO mod to their Sync2 where you replace the board in the back of the APIM and you keep all the functions of the SYNC2, but yet you can also wirelessly jump into Carplay?  It's $400.00 but seems so simple, 1 part and poof wireless CarPlay...Has anyone taken the plunge and if so, happy, sad, mad??

Share this post


Link to post
Share on other sites
32 minutes ago, TxBucki said:

Has anyone done the VISKOO mod to their Sync2 where you replace the board in the back of the APIM and you keep all the functions of the SYNC2, but yet you can also wirelessly jump into Carplay?  It's $400.00 but seems so simple, 1 part and poof wireless CarPlay...Has anyone taken the plunge and if so, happy, sad, mad??

 

You would have to be the first.   You get to improve or restore life to a dying MFT/ SYNC2 unit.   I guess this could be a cheaper alternative than swapping in complete SYNC3 kit.

Share this post


Link to post
Share on other sites

Found 2019 Edge display and APIM for $150.00....Had to go this route...Having some bugs on new one (FORSCAN codes), but working thru them.  Have a new post with those problems if anyone wants to help  ;;)

Share this post


Link to post
Share on other sites

Hello to all,

yes, I bought the kit and the installation was simple and without any issue.

 

as for steering wheel control, only volume buttons working. (Edge eco boost 2014 sel+)
as soon as you understand that you have Siri on board, it’s not a problem at all. 
highly recommend upgrade 

81D4957C-5A13-4E9D-92D3-9A7EE35848DA.jpeg

DA8E71D1-C301-49F7-AE78-BFF1CFC9C230.jpeg

Share this post


Link to post
Share on other sites

Thanks.  Looks like you’re the 1st.  Did the climate control work on screen or do you have to use hard buttons? I guess you can switch between the 2.

Share this post


Link to post
Share on other sites

Hi Eran - glad to hear of your success.  I'm having trouble installing into my 2014 Edge Ltd with the Sony stereo.  The metal shroud around the screen and the case the new motherboard is mounted in are different than mine. The screws holding the screen in now interfere with the screen shroud and the motherboard case doesn't have the holes to remount the pull handles/mounts. Any tips?

Share this post


Link to post
Share on other sites

Hi losteaglescout , 

post some pics so I can see the problems. Than maybe I can help you from my experience. 
 

about steering control, I found out the if I choose as input device Bluetooth streaming, all the controls are operating as expected. Vol up and down, seek, answer phone calls etc’

 

after 1 year with the upgrade, I’m super happy with the viskoo. Working perfectly 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×