Jump to content
TxBucki

2012 ACM upgrade with 2019?

Recommended Posts

Hi..Installed new sync 3 from 2019 Edge and radio works, steering wheel buttons work, heated seats work on home screen only - not on Climate screen.  What doesn't work is anything on the Climate screen - the hard buttons work but not the touch screen, rear camera will not come on, and the worst right now, is that when I turn the car off, open the door, the radio still is on and I have to push Power/Vol button to turn off.  The AC shuts off, but not the radio.

 

Here is my set up and what I have so far...I had to make some changes as something was strange as for 7D0-01-02 the 2nd block of numbers had 4000 -  4=Diesel Vehicle, SWAC Not Available

 

Any help would be appreciated.. 

 

 

2012 AsBuilt.PNG

Edge Console.PNG

Modified APIM Settings.jpg

Share this post


Link to post
Share on other sites

Update:  I think I have most of the codes correct, much easier seeing them in text rather than those stupid codes, but...It seems the APIM does not know that my car is ON, or running, as I have to push the power button on the radio to turn it on.  It will stay on for 30 min (as that is what it's supposed to do  - Radio without ignition switch play time.  As I'm after 30 min it will just turn off.  Also, when I turn the car off, it stays on, even after opening door.  Again, I don't think it recognizes the car is off, so I have to push the power button to turn it off.  I did NOT have this problem with the Sync 2.  Are there some codes that need tweaking, or do I have a bad APIM, or???  Any help would be appreciated...

 

466512316_RadioAPIM.PNG.0c357c4cf600ab8678501ed460333c6a.PNG

Share this post


Link to post
Share on other sites

Plowing thru other treads, and could it be the ACM?  Not sure if ACM is sending enough signal power to initialize APIM, or something is not sending signal at all to APIM or??  Not sure how to test this.  I read that ACM would need to be at a certain firmware (after 2016, mine is 2012).  I also read that since I have 2019 Sync 3, ACM is part of APIM...

 

So confusing...

Share this post


Link to post
Share on other sites

Can you replace ACM from 2012 with later model ACM without any issues?  Upgraded Sync 2 to 3 (2019 Edge) and I suspect ACM issue as it will not turn on audio when I crank car

Share this post


Link to post
Share on other sites

2012 Ford Edge SEL.  Upgrade from Sync 2 to Sync 3 Version 3.3, Build 18201.  Got the Sync 3 from salvaged 2019 Edge

As Built
APIM      7D0-01-01     2221     9000     610D 
APIM      7D0-01-02     0003     4000     021F   The 4000 is strange as this means it's a diesel (I think)
APIM      7D0-02-01     5553     0004     0086 
APIM      7D0-02-02     0000     0000     00DB 
APIM      7D0-02-03     0000     DC      
APIM      7D0-03-01     0052     3900     0066 
APIM      7D0-04-01     0103     0200     00E2 
APIM      7D0-04-02     0001     DE     

 Put back to AsBuilt..Unplugged battery for a couple/few hours..same symptom "Audio Off".  Tried again to run APIM test, get "The vehicle conditions are not met" error.  When I do click the test button (making sure the conditions are met), the lights flicker like it's trying to do something, then this error pops up.  

 

Also, this has been present from the get go after the swap (see attachment), Climate screen display is missing temperature numbers and does not work to the touch.

image.png.66a555a19cd5f09b643206e8013ee9a1.png

 

I suspect I have bad APIM...Just for fun, I'm going to try radio (ACM) swap to see if that's it..

Thoughts?

Share this post


Link to post
Share on other sites

Swapped out radio (ACM) and same..New radio works, but did not change anything.

Share this post


Link to post
Share on other sites

When I upgraded my wife's 2015 Mustang to the 8" screen with Sync 3, the person that I bought the kit from, re-programed the APIM to work in our M/Y Ford, in addition to specific changes made using Forscan. .

 

You could contact him on the Mustang forum - HextallS550

 

https://www.mustang6g.com/forums/threads/sync-3-swap-its-all-in-here.82973/

Edited by 1004ron

Share this post


Link to post
Share on other sites

@TxBucki if you can't figure out the proper APIM programming there are a few sources on the internet that can supply proper programming for a fee.  You many want to consider that.  

 

Also be aware that with an APIM running 3.4 software your dual climate will not work correctly from the SYNC unit and as Ford pushes out updates more features may not work right as that generation APIM was never intended to be used in a CGEA1.2 vehicle such as your Edge.  So if you upgrade from 3.3 that will not function right.

Edited by jmr061

Share this post


Link to post
Share on other sites

Thanks for heads up on 3.4.  I have read that 3.4 is risky so I’ll avoid that.  I have most if not all the programming done (with Forscan), but it will just not come on when I turn the key but rather I have to push power button on radio.  Maybe that is programming somewhere that is just not obvious.  I wish I knew if I had a good APIM or not..

Share this post


Link to post
Share on other sites
17 hours ago, TxBucki said:

2012 Ford Edge SEL.  Upgrade from Sync 2 to Sync 3 Version 3.3, Build 18201.  Got the Sync 3 from salvaged 2019 Edge

As Built
APIM      7D0-01-01     2221     9000     610D 
APIM      7D0-01-02     0003     4000     021F   The 4000 is strange as this means it's a diesel (I think)
APIM      7D0-02-01     5553     0004     0086 
APIM      7D0-02-02     0000     0000     00DB 
APIM      7D0-02-03     0000     DC      
APIM      7D0-03-01     0052     3900     0066 
APIM      7D0-04-01     0103     0200     00E2 
APIM      7D0-04-02     0001     DE     

 

 

If this is what you are using for SYNC3, its way off.  

  • Like 1

Share this post


Link to post
Share on other sites

This is as built codes I figured I'd give that a try and do hard reset.  Did not fix anything.  At the beginning, I did play around and got to this.  Same issues though.  No Power then turn car on, but have to use power button on radio, then sync comes on.  Have to turn off the same way.  Also, climate screen is there, but nothing works and no temp numbers are there.  Here is the latest APIM codes:

 

Sure is frustrating...

Last APIM.jpg

APIM Climate.jpg

Share this post


Link to post
Share on other sites

My understanding is that the APIM needs specific programming in addition to a few Forscan parameters.

Share this post


Link to post
Share on other sites

I reached out to Dan at syncprogramming and he states he believes all my issues are programming related.  Let’s find out…

Share this post


Link to post
Share on other sites
26 minutes ago, TxBucki said:

This is as built codes I figured I'd give that a try and do hard reset.  Did not fix anything.  At the beginning, I did play around and got to this.  Same issues though.  No Power then turn car on, but have to use power button on radio, then sync comes on.  Have to turn off the same way.  Also, climate screen is there, but nothing works and no temp numbers are there.  Here is the latest APIM codes:

 

Sure is frustrating...

Last APIM.jpg

 

26 minutes ago, TxBucki said:

I reached out to Dan at syncprogramming and he states he believes all my issues are programming related.  Let’s find out…

Yeah those are way wrong...it has to be programmed specifically for your vehicle which it clearly is not.

 

If you messed with the ACM programming that needs to be changed back to what it was originally as well.

 

There are cheaper places to have it done too.

  • Like 1

Share this post


Link to post
Share on other sites
23 hours ago, 1004ron said:

When I upgraded my wife's 2015 Mustang to the 8" screen with Sync 3, the person that I bought the kit from, re-programed the APIM to work in our M/Y Ford, in addition to specific changes made using Forscan. .

 

You could contact him on the Mustang forum - HextallS550

 

https://www.mustang6g.com/forums/threads/sync-3-swap-its-all-in-here.82973/

 

15 hours ago, jmr061 said:

@TxBucki if you can't figure out the proper APIM programming there are a few sources on the internet that can supply proper programming for a fee.  You many want to consider that.  

 

 

 

15 hours ago, TxBucki said:

Thanks for heads up on 3.4.  I have read that 3.4 is risky so I’ll avoid that.  I have most if not all the programming done (with Forscan), but it will just not come on when I turn the key but rather I have to push power button on radio.  Maybe that is programming somewhere that is just not obvious.  I wish I knew if I had a good APIM or not..

 

1 hour ago, 1004ron said:

My understanding is that the APIM needs specific programming in addition to a few Forscan parameters.

 

1 hour ago, TxBucki said:

I reached out to Dan at syncprogramming and he states he believes all my issues are programming related.  Let’s find out…

Dan told you what others have been advising here.

Share this post


Link to post
Share on other sites

Have you done the wiring changes mentioned below?

 

https://sync3programming.com/Sync-3-APIM-Programming-for-FORScan-via-Email-p112322808

Quote

Note: 4" Displays to 8" Sync 3 Conversions will typically REQUIRE wiring changes and repining Ford wiring connectors to a different configuration, unless a custom wiring conversion harness is utilized.

 

Share this post


Link to post
Share on other sites

Luckily I’m going from 8” sync 2 to 8” sync 3.  I have the USB, GPS, and wiring gizmos.  Interesting fact I learned, my sync 3 is 3.3 and my 2012 Edge will NOT have all the functions. This what I’m seeing.   I need 3.0 or less

Share this post


Link to post
Share on other sites
7 minutes ago, TxBucki said:

Luckily I’m going from 8” sync 2 to 8” sync 3.  I have the USB, GPS, and wiring gizmos.  Interesting fact I learned, my sync 3 is 3.3 and my 2012 Edge will NOT have all the functions. This what I’m seeing.   I need 3.0 or less

Where did you hear this?

Share this post


Link to post
Share on other sites

From HextallS550 on mustang6g.  There is a thread about 140 pages for a ton of info going from 4” to 8” but for my situation the electrical architecture is different.  

Share this post


Link to post
Share on other sites
22 minutes ago, TxBucki said:

From HextallS550 on mustang6g.  There is a thread about 140 pages for a ton of info going from 4” to 8” but for my situation the electrical architecture is different.  

That is because he mainly deals with 15 plus Mustangs which runs CGEA1.3...he doesn't know everything.  I have been dealing with SYNC stuff since 2013 and I don't know everything either, always room to learn.  Yes the CAN BUS system is different.  It's programmable though.  I suspect Ford is writing the older can bus out of the newer software which is why dual climate won't work with 3.4 via SYNC (works fine if you have hard controls though) as I stated earlier.  The newer generation of APIMs were never installed in the older can bus system from the factory so they have no reason to keep supporting it.   I don't recommend your specific APIM be used in your vehicle but that doesn't mean basic things won't work.  If you stay with 3.3 you will be perfectly fine as long as it is programmed properly.  

Edited by jmr061

Share this post


Link to post
Share on other sites

A lot to think about for sure.  So many variables and I too am learning a ton.  My 3 main things are the turning on/off sync with radio power button (don’t like that at all), rear camera, and climate screen.  

Share this post


Link to post
Share on other sites

I’ll say it one more time…

 

Pay someone to program it properly.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×