Jump to content
Sign in to follow this  
edkene

Rough Idle When Cold/P0301 Code

Recommended Posts

Hello All,

 

First off, I have a 2016 Ford Edge 2.0L Ecoboost SE with 63,XXX miles on it. I am the original owner. 

 

Looking for a bit of help. A while back I started experiencing a rough idle immediately after filling up my fuel tank (allowed the handle to pop; never topped it off). Shortly afterward I started having rough starts in the morning when it got cold and then it popped a CEL. I pulled the code and it was a P0301, Cylinder 1 Misfire.

 

I did some research and came across people who were reporting that the issues with rough idle immediately after a filling up a tank were typically caused by a bad Fuel Vapor Separator/Valve (part number F2GZ-9D289-A, if anyone ever needs it). I replaced it (a bit of a pain...story of another time) and I reset the ECU (disconnected the battery and stepped on the brake for about 10-15 seconds). Things were better for about a day, and then I got the rough idle while cold and it popped the P0301 again.

 

In my research I noticed a couple of people mentioned that replacing the Fuel Vapor Separator/Valve didn't always do it and that you needed to replace the Fuel Vapor Solenoid (part number 9U5Z-9F945C if anyone needs it). I got the part and replaced it (again, a bit more of a pain than I expected - story of my life). Again, I reset the ECU after replacing the unit. The vehicle started and ran fine immediately after replacing it and the next morning when it was cold. When I started it up after work I got the rough idle again and popped the same code (P0301). 

 

Question for everyone: what am I missing? This thing has all the hallmarks of a bad EGR valve (slight smell of gas, poor gas mileage, rough idle at start) but as far as I can tell these vehicles don't have it. When I look at the shop manual for the vehicle it gives the following for reasons for a P0301 code:

  • Ignition System
  • Fuel Injector 1 
  • Running out of Fuel
  • EVAP Purge Valve 
  • Fuel Pressure
  • Evaporative Emission System
  • Exhaust Gas Recirculation (EGR) system
  • Base engine
  • misfire monitor neutral profile correction has not been relearned since the last mechanical repair

 

The full list of issues are:

Rough Idle When starting

Slight Smell of fuel

No rough idle for the first start or two after resetting the ECU

Changed out the Fuel Vapor Valve

Changed out the Fuel Vapor Valve Solenoid

Poor fuel economy

After start up and the engine has been running for 10-15 seconds, no more rough idle. Can normally get past it by having the engine rev for 3-5 seconds

 

Any help on this would be greatly appreciated.

 

 

Share this post


Link to post
Share on other sites

Welcome.  As soon as I saw 2016 and 2.0 and a misfire code, I was ready to cry lol.

 

It may simply be the plugs need changing.  ecoboosts eat plugs for lunch, and 60K is a good interval to change them anyway regardless of engine.

 

if a plug change/code reset does not fix the problem, you MAY be looking at a coolant intrusion problem.  check the engine label on the right side of the valve cover.  post a pic plz.  does it say Cleveland or VEP.  how is the coolant level? you will want to mark current level with a marker, then follow progress daily/weekly.

 

do you have remaining ford warranty?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×