Jump to content
TxBucki

2012 Troubleshooting P0299

Recommended Posts

Keep getting P0299 code and suspect Turbo wastegate as the code indicates, but I have seem where many other factors may play into this code so you don't necessarily have to replace the turbo itself.  I did check the hoses and don't see any holes or loose clamps.   Is there a way to test Turbocharger sensor assy or the Turbocharger wastegate regulating valve solenoid, or finally the Turbocharger bypass valve?  I do have some play in the linkage to the wastegate but not sure how much would be too much play and can you adjust this?  I may take off the exhaust that connects right by the wastegate and see how much play is there, but if there are easier things to do before that, I would want to try...

 

Thanks..Ed

Share this post


Link to post
Share on other sites

Did you mistype 2012, or are you driving a  GEN1+ EcoBoost FrankenEdge?

 

So that I may pull the proper diagnostic procedures: Is that a 2.0L or 2.7L ?

 

The generic DTC descriptor from the 2022 Edge Workshop Manual...

 

DTC Fault Trigger Conditions

PCM P0299:00 Turbocharger/Supercharger 'A' Underboost Condition: No Sub Type Information Sets when the PCM detects the actual turbocharger boost pressure (TCBP) value is less than the desired turbocharger boost pressure (TCBP) value by 27.6 kPa (4 psi) or more for 5 seconds, indicating an under boost condition.

 

Check tubing for restrictions, cracks and incorrect fitting connections.

 

Check the turbocharger wastegate regulating valve solenoid for correct operation.

 

Good luck!

Share this post


Link to post
Share on other sites

It's a 2012 Edge with Eco Boost 2.0L.   I checked all the hoses...Seem to be good.  The linkage to the wastegate is loose for sure..I really suspect that is the issue (or the wastegate itself) but will not find out until I take it off.  It seems like a pain, but something new... In the process of doing that now...Is there a way to test the wastegate regulating valve on the car?

 

Thanks..

Share this post


Link to post
Share on other sites

generally the breakage is inside the turbo with the wastegate. i think 1 or two people have repaired it successfully but have no documentation to that effect.

 

best bet is to replace the turbo.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×