Jump to content
Sign in to follow this  
Zeb

Vibration in Gas pedal

Recommended Posts

I hve a new 2010 Edge SEL and when you step on Gas pedal it vibrates until you hit 40 MPH. After that it is fine. I took it to the Dealar and they said it was normal for that model. I find it hard to believe, so with that being said, has anyone else experienced this problem and if so, what was done to fix the the problem. The mileage is at 2,300. Any feedback would be appreciated.

Share this post


Link to post
Share on other sites
I hve a new 2010 Edge SEL and when you step on Gas pedal it vibrates until you hit 40 MPH. After that it is fine. I took it to the Dealar and they said it was normal for that model. I find it hard to believe, so with that being said, has anyone else experienced this problem and if so, what was done to fix the the problem. The mileage is at 2,300. Any feedback would be appreciated.

 

The problem is with the dealer not knowing what to fix. So, tell the dealer that you don't think that Ford would design an expensive vehicle like the Edge with a built in problem, do you? Why don't you get some experience by fixing this one. Then you can be a hero and fix all the ones on which you have seen this problem.

If they still are reluctant to help, call the Ford 800 line or try a different dealer.

Edited by flyerjmr33

Share this post


Link to post
Share on other sites

I'm not sure what might cause a vibration in the gas pedal as there is no physical connection between the pedal and the engine. the pedal only sends an electric signal to the pcm and the pcm controls the throttle motor. I'm not sure what the pedal assembly is bolted too, but it would have to whatever it is bolted to that is causing the vibration.

Share this post


Link to post
Share on other sites

I have a 2008 Ford Edge and I had a similar problem but the vibration was from the console area but felt it down to the gas pedal.

 

These kind of problems can be hard to trouble shoot. The vibration was noticeable between about 30 to 60m/hr and was more noticeable when accelerating/decelerating.

 

I took it to the Dealer and drove it for the mechanic so he could feel it.

 

My problem turned out to be a drive shaft that was improperly milled from the supplier (in Mexico). Ford had a new one couriered out from the manufacturing plant in Oakville, ON Canada.

 

It was replaced under warranty and the problem went away.

 

Make your dealer look into further.

 

I logged my problems on my blog www.smokinedge.com

Edited by garyedwardsmith

Share this post


Link to post
Share on other sites

All, Thanks for the feedback, I will take it back to the dealer and ask them to relook at the issue. Thanks to all

Share this post


Link to post
Share on other sites

Hi, I'm just wondering if you had found a fix to this vibration problem. I just picked up a new 2012 Edge SEL AWD and have been experiencing similar vibration from the gas pedal. Under moderate acceleration, the gas pedal vibrates and usually in the lower mph (5-40). I didn't feel anything else vibrating. It's fine when I gas it while parked. I have an appointment to bring it in but any information would help. Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×