Jump to content

bobby_80s

Edge Member
  • Content Count

    3
  • Joined

  • Last visited

About bobby_80s

  • Rank
    New Member
  1. 2008 Edge Fan blower was tested with a direct battery and it spun. I get no voltage at the fan connector. it does not work on any speeds. fuses look good and relay was swapped with another one from another edge and still nothing. so because it doesn't even work on high makes me think its not the resistors. soo.... could it be the climate control switches??? I have no clue I tested what I could and its going to the dealership today but would be great if its something I can check and fix myself! any ideas?
  2. alright thanks, did seem to happen around the same time my dad told me to use the AC just to keep the system fresh or something like that. I try to have my windows down whenever I can to save gas, but relays seem to be ok. my next question is how likely is it the AC/HEATER controller switches are bad and not giving power to the fan? relays an fuses seem to be fine.
  3. I just recently bought a used 2008 ford edge. just recently after a hard rain I noticed water dripping out of passenger side dash floor area when I drive I can hear swishing around inside the dash. NO CLUE HOW ITS GETTING IN. the drainage under the windshield is free flowing then just last night I tried getting some AC. and the fan doesn't work at all. I took it out from the passenger side dash and it was filled with WATER! theres a plastic air passage that seems to the final end of where the water reaches the fan but I have no idea where it starts to accept water. Tested the connector to the fan no power.... anyways fuses are fine........don't know how to test the relay so its ordered and be here tomorrow. hooked up a battery to fan directly and IT SPINS! so my last guess is the relay unless someone has other ideas. and anyone else have problems with water getting in?
×