Jump to content

1000wordsSTL

Edge Member
  • Content Count

    9
  • Joined

  • Last visited

About 1000wordsSTL

  • Rank
    New Member
  1. 1000wordsSTL

    2010 Edge front end click / pop *PLEASE HELP*

    LOL macbwt that's for sure! I don't think it was the smartest thing for them to do, with a waste of both of our time and trouble but it sure is nice having the extra parts! A blessing in disguise I say. You're right WWWperfA- I do go to a lot of trouble to not get people in trouble. It's because I understand what it's like to deal with irate people all the time who really don't even have a good reason to be irate, lol. I had a good reason but I was trying to be fair. I had visited this dealer for 15 years and bought 3 cars from them. One of my perks of buying a Ford was that I could deal with the same people I always have who have never made me (up till this point) feel like a silly girl. These guys have always taken me seriously and would always point out what I really needed to have fixed vs what I really didn't need to do. I have never felt taken advantage of. My favorite person there quit and there is new management, hence the problem. Trust is key and I don't have that here anymore. I suppose I should think of the next person in line, however it was a long history of loyalty to the same people who had me going here- not an online review, Car142. I do agree that contacting Tricia is the best thing to do. I don't have to write the BBB, but someone should know.... Thank you all for your help with this!!!!
  2. 1000wordsSTL

    2010 Edge front end click / pop *PLEASE HELP*

    Good Morning All! I'm happy to say that I finally got my car back Friday and have driven it all weekend with no more noises! On my fourth trip they replaced both of the upper strut mounts and the bearings, and they replaced the transmission mount. I have been asking them to check the strut mounts since it was first mentioned here- I guess they finally did what I asked on the last visit..... I didn't contact Tricia with FordService because I was concerned about somehow getting the dealership in trouble- I thought since the manager was back from vacation it would be best to give him a chance to make things right. He was very nice about the whole thing and very apologetic. There are a couple of things that still bother me and I'm not sure if I'm being too particular or if they are things that should bother me. I work in management for a customer service team at an alarm company and I know how I am expected to treat my customers. There are a few parts about this whole deal that I can't seem to shake. Not calling me back is only part of it- I had to call them on Thursday to get an update after hearing nothing since drop off Monday, although I'd asked for an update. I know I can go to certain outlets and complain or write reviews. I'm not sure if that's what I want to do, but I do know that I will not be taking my car back to that shop again which is pretty sad seeing as how they have kept my business for 15 years. First, I don't understand how when I went in the very first time with the noise, they "tightened" my drivers side half shaft. Everyone I have said that to has looked at me like I have two heads. If it's loose wouldn't it have been bad, and warranted a replacement? On my second trip they replaced the drivers side half shaft and I asked them to look over everything else- I was told by the supervisor that the rest of the car looked great but that I should keep in mind that once one shaft goes the other one can go in the future..... On my third trip they replaced a wheel bearing/hub assembly on the drivers side but said all else looked great. I didn't leave with my car that night, and instead had them drive it with me because it still made the same noise in the lot. That time they replaced the passengers side drive shaft and wheel bearing/hub assembly. I have been told by multiple people that saw the car that day that the drive shaft was BAD and that it was very "loose"- definitely requiring replacement. When I finally picked up my car and spoke to the manager last Friday he was saying that they all thought for sure it was the drive shaft because it was in such bad condition. I asked how it could have come to that and been unnoticed, being that I am religious about my car maintenance and they are they only service shop I take it too. He told me that maybe I hit a pothole and that the "clamp was loose" on the shaft. He also said it's not something you can see when the car is up in the air so they wouldn't have noticed it, even though I pay for a "multipoint inspection" each time I have my oil changed...... And in the end the problem wasn't even these parts- it was the strut mounts and the tranny mount which are two items I have told them to check for the last 3 visits. How could they miss the other items replaced IF they truly did need replacing? And one other item I may have forgotten to mention.... the 3rd time I actually took the car home, prior to the strut/mount replacement, I was checking things on the outside that could see on the front end that might be making a noise. I don't know- I mean my bug deflector has made noise in the past so I was just trying to rule things out. I looked up in my drivers side wheel well and found about 4 inches of thin black foam sticking out from between the wheel well covers up by the spring. I can send a photo if needed.... I ended up pulling on it and it's obviously some sort of sound buffer- long and flat and shaped like half the well. I actually handed it to the tech who rode with me on the final trip to listen- he laughed and said he would put it back up. I was also missing one of the plastic clip/covers for the wheel well. I had a list of the TSB's from here, photos of where I got the foam from and also a couple other posts I thought might help and brought it with me to give to the supervisor. Since he wasn't there that night and the manager seemed so mad at his employees, I gave it to the tech who rode with me that was to be working on the car the next day. He said to just put in the back seat and they would look at it. So it's still in the back seat and so is my piece of foam. I didn't realize this till after I got home. I actually had called the dealer the next day to talk to the supervisor to avoid the manager knowing about the foam and getting anyone else in trouble. I explained to him that I just had a packet of print outs for him to look over to try to help them figure it out, plus a photo of a piece of foam that they needed to put back. He said he would take care of it. Obviously no one did..... Again, not taking my car back there, but wondering what I should do at this point? The car seems fine, but would anyone here suggest me taking it to the other dealer that had the best ratings in my area to double check things? Should I be concerned that this piece of foam is not in my wheel well and does someone need to put it back? Or do you all think I should just wait till time for my next oil change, then take it to the new dealer service department and ask them to look over everything? I'm not sure if I want to tell them about my crazy experience with this dealer, as I don't want to appear to be a pain. And that's the thing- throughout all of this I was extremely nice to everyone and very understanding about the drama. I was the kind of customer I would want to deal with. Thoughts?
  3. 1000wordsSTL

    2010 Edge front end click / pop *PLEASE HELP*

    Thank you Tricia! I will PM you all of my info. ? Still nothing new to report today..... Day 2 of car at the dealer and no one calling me for an update. Hoping for better luck tomorrow. Any help you can provide would be much appreciated! ?
  4. 1000wordsSTL

    2010 Edge front end click / pop *PLEASE HELP*

    Thanks mac- maybe that's the problem? ? Absolutely nothing new to report today.... I called the same supervisor I had been dealing with and let him know about the copies on the seat for him. I asked him to check the items that had been mentioned on this forum and he said he would make sure the tech did that. I told him I didn't want him to rush on anything to get it done today but if I could just get an update at day's end that would be great. No call.... So I suppose they are still trying to solve my mystery. I did do some checking on dealer rater and edmunds on the dealership I'm using and others in the area. Only a few reviews for this dealer and all are great. Best one is the one I will take it to for my next oil change. I can't feel right about this. When I was with the tech driving last night I was expressing my concern about just changing out parts without truly knowing, etc. He said that while he did not work on it on Friday he did help do some listening and he did truly think it was the passenger side drive shaft because it was making noise and did need to be replaced. If that's the case then why two trips ago over this mess after the drivers side drive shaft was replaced and I asked the supervisor for them to take a close look at everything else and report back did he say that my car was in "great working order"? Obviously according to the tech the other side needed to be changed out. I got a sneaking feeling that the techs are behind those glass windows away from the public for a reason- because they are more honest than the service writers at the desk.... They know I have 8k worth of a warranty left and I feel like they would like to not tell me about some needed repairs to make a buck in the future. Thanks again! ? Hopefully I will have some good news tomorrow!
  5. 1000wordsSTL

    2010 Edge front end click / pop *PLEASE HELP*

    Thank you! I'm crossing all my fingers and toes!
  6. 1000wordsSTL

    2010 Edge front end click / pop *PLEASE HELP*

    Thank you both for your suggestions and advice! And wow, macbwt- great to see how long you've had your Edges. Nice to know they can be in it for the long haul! I've loved mine and never had issue till this latest problem. So I went back to the dealer tonight and was prepared to just drop it off. I knew the supervisor wasn't in today but he had told me to leave it for him tonight to get involved Tuesday when he was back. I printed out the TSBs you all so kindly added to this thread above. I also had a photo of my odd foam piece in the well before I removed it so they would be able to see where it came from. When I got there a service advisor, the top manager and a tech I had not met were literally waiting for me. The manager whom I've known for years has been on vacation for the majority of my visits and just came back today. He asked me to let the new tech ride along to hear the noise. We get in and I explain what's going on for what feels like the millionth time. I show him my foam piece which he apologized for amd said he would take care of. We drive out of the lot and.....click. We drive through the lot next door and we hear it a few more times. He asks to drive so I let him and we do so for about 20 min. I explain when it typically makes the noise and it happens severs more times. He tells me he remembers the car when it was in last week and said lots of mechanics were under it trying to figure it out. He said that they were so sure that it was the half shaft on the passenger side because they listened to it with a "steathescope" and found there was definitely a problem with the shaft. I showed him the TSB that I was given and he said that my particular shaft doesn't have a washer but that yes the washer can be loose and cause a similar noise. We talked on about other possibilities and he really felt like it has to be something with the axle or front suspension because of when the car makes the noise. We get back to the dealer and the tech tells the manager he heard it. They discuss for a few moments what to do and the manager seems pretty mad. He's saying how he can't understand how they let me leave all these times with the problem still occurring. He said someone should have driven it longer to make sure and apologies saying that if he wasn't gone it wouldn't have taken this many trips. I compliment everyone I've worked with thus far because they have all been very pleasant and I've enjoyed taking my cars there over the years. I didn't bring out the paperwork and instead left it in the car where I had told the tech it would be. I'm not in the business of trying to get people in trouble and make enemies. Since it's clear that the supervisor has informed the manager on all the issues, I think I will call early tomorrow before they work on it to talk to him when he's back to work. I'm going to let him know about the paperwork in the car and that I want the items addressed here checked too. The tech actually thanked me for all of that saying most people don't do the research and that its great I do because anything helps. I will update tomorrow! Thanks a MILLION!!!!!!
  7. 1000wordsSTL

    2010 Edge front end click / pop *PLEASE HELP*

    Thanks again! Would you suggest I print out the TSBs you attached for me and ask them if all of the parts listed were replaced with the approved replacement parts? I'm sure they will say something about this not being a TSB for my vehicle but if there have been so many that were needing to be replaced in so many models, mine just may not have been included just yet. I do have and keep all my receipts for the work that they do. They don't have part numbers on the receipts just a description of what work was done and parts replaced. As I said before, my receipts for both the left and right half shafts just say "replaced drive shaft and nut". The receipts for the wheel bearings say "replaced hub assembly" for both the left and right. I'm definitely thinking of going to another Ford dealer and am honestly not sure how long I should continue to give this dealer to find and fix the problem. The warranty I have is the ESP through Ford and it is the bumper to bumper coverage till 100k miles with the $100 deductible. At this dealer I have only had to pay that deductible one time because they have not completely solved the problem. Another dealership would have me start over but if they are going to fix the problem it would be worth it. I've never faced anything like this before....
  8. 1000wordsSTL

    2010 Edge front end click / pop *PLEASE HELP*

    Thank you SO much for the reply! I will tell them to check the strut mount / bearing as well and update after my next appointment tomorrow on what they find. Where would the washer be that you are speaking of? On the half shaft? Any thoughts on the dealer and the job they have done? They're very nice but I can't for the life of me figure out why they can't just drive the car when finished to check up on the noise. I think the biggest issue is that there are took many fingers in the pie so to speak- maybe word is not passing down correctly and I know only 2 techs and the service advisor have heard the noise. According to them this is a huge mystery but when I ask about parts checked I don't get specifics. I have asked them to check EVERYTHING and am puzzled by the fact that its still not found. Does the paths that they have taken thus far make sense? I'm so incredibly thankful that my warranty has covered all this!!!! Your advice is much appreciated!
  9. Hello everyone! I'm having some trouble with my 2010 Ford Edge FWD LTD and am hoping you may be able to steer me in the right direction. My Edge has 92k miles on it and has never really given me any trouble other than a creaking noise when going in and out of my drive way a few years ago. That was a motor mount and it was replaced under warranty- there was a TSB on the issue as well. About a month ago I started noticing a click of a pop noise coming from the front end. I would notice this mostly when I was increasing speed on the highway and would let my foot off of the gas, taking off from a complete or rolling stop and in stopping. To me it sounds like something is loose somewhere and the noise is connected to the shifting weight of the vehicle when you stop or start. It would also happen when making turns either way especially when there is an incline. Sometimes it will happen when the car is jarred going over a bad spot in the road as well. So again to me, the noise occurs when the weight of the car shifts. It can't be replicated by bouncing on the car when it's in park and it does not happen all the time. It's sporadic and not super loud. So I took the car in to the dealer as it is still under my warranty 3 weeks ago to have it checked out with an oil change. They told me that the "drive shaft was loose" and they tightened it up..... I didn't question it and went on about my business. On the way home the noise was still there so I called and made another appointment. This time they replaced the drivers side half shaft. I drove the car home, noise still there so I brought it back. This time they said it was the drivers side wheel bearing/hub and they replaced that as well. Noise still there when I drove it off the lot. I took it back again refusing to drive it home. The dealer kept it for a couple days and this time when I picked it up they said they replaced the passengers side half shaft and wheel bearing / hub. By the time I reached my house the noise was back..... I am planning to drop it off again tonight at the dealer. Two techs have driven the car with me and heard the noise. One thought wheel bearing and one thought a mount. They say they have checked but sometimes these noises are hard to pinpoint. Last night in desperation I went outside and kind of looked up in my drivers side wheel well just to see if anything seemed loose to my untrained eyes. Well, there were a couple of bolts/covers missing where they must have removed be plastic wheel well cover and there was a good sized piece of foam sticking out from two pieces of the well by the shock/spring. I pulled it out and saved it so they can put it back..... I have trusted this same dealer service department for almost 15 years. I really like the people there and they don't treat me like I'm just a girl. But this most recent episode is beginning to wear on my nerves. After the 3rd time bringing it over there I told them I didn't want it back until they had found and fixed it. Someone needed to test drive it to ensure its completely resolved before I come up there. It's an inconvenience to keep finding rides.... By the time I got home on Saturday and heard that noise again I called the manager again and he was so sorry for not having driven it himself because he knows the noise they are looking for. He said that he wants me to take it back when he's there- tonight and leave it again. He told me that sometimes noises are just hard to find so its great I have this warranty where they can throw parts at it to try to take care of it since it's not an obvious fix. I asked if I should go to a different dealer and he said definitely not, his are the best, etc. I don't have a list of parts they have looked at but at this point I would like to be able to help give ideas on what it could be. Any thoughts? I have read sway bar/ bushings, control arm bushings, strut bearing mounts and clips, and ball joints. Anything else? I also read Cv joint. Is that the same thing as a half shaft? My receipt says drive shaft and nut were replaced. Any help would be greatly appreciated! Thank you!
×