Jump to content

mQbiZkit

Edge Member
  • Content Count

    9
  • Joined

  • Last visited

About mQbiZkit

  • Rank
    New Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. My 2011 Edge Sport sunroof seems to be getting hung up on the seal for the rear track. I noticed it’s coming undone and super soft and tacky. Does anyone have the part number for this piece?
  2. mQbiZkit

    Charging issues...

    I haven’t made it back to the car this weekend. Am going to try this coming weekend.
  3. mQbiZkit

    Charging issues...

    1004ron sorry about not putting all the info in. The battery saver thingy mode is what got me. I’ve never seen that and when I did some research it came back as battery was weak and it was shutting down things to help the battery be able to start the car. Well we had replaced the battery about 6 months ago and now it’s dying again and with this battery saver notification. So I just changed out the alternator this past Saturday figuring it was not charging the system adequately. Now the accent lights flicker and the interior lights and dash lights dim and brighten with the rpm’s. I won’t be back in Houston where the car is for a couple more weeks. Is the BA-7 something a parts store might have on hand or is it an item that will have to be ordered?
  4. mQbiZkit

    Charging issues...

    I have not but my wife just told me that it makes a sound at times behind the dash or in the engine compartment that sounds like “clicking” or trying to start It with a dead battery. We don’t live in the same town and I won’t get back there for another week or two now. I did load test the battery VDC not running had 12.9 and had a constant 14.59 +/- vdc running with the radio, seat heaters and AC on she kept her voltage around the same. Autozone did load test the battery in the car running and it came back good, out of the car 12.7 and was good. I did put a remanufactured alternator in there. It was a pain in the ass to get in but i still have the old one and can and will put it back in the car if need be.
  5. mQbiZkit

    Charging issues...

    That’s just it the battery is less than 6 months old. Not sure how long the Alternator has been out. I’m afraid it’s been running off just the battery.
  6. Ok I have a 2011 Edge Sport 2WD The display has been throughly out the battery saver on the display. Got the battery checked and they said it was ok and to look into the charging system. So I went ahead and replaced the Alternator last night. I put the battery on a charger to get the charge up on the battery for the initial start up. Now when I start the car up there is no battery saver on the display but I’ve noticed all the lights flicker then brighten and dim when the RPM’s raise and lower. Could this be a bad battery now? what else am I missing
  7. mQbiZkit

    2011 Ford Edge Sport 2wd

    just wanted to drop a line. We are proud owners of a white 2011 Ford Edge Sport 2wd and we love it. 144K+ miles a few issues but still love this gem.
×