Jump to content
Ford Edge Forum

Froggy372

Edge Member
  • Content Count

    2
  • Joined

  • Last visited

About Froggy372

  • Rank
    New Member

Profile Information

  • Region
    U.S. Northeast
  • Current Vehicle
    2007 Ford Edge SEL AWD 3.5

Recent Profile Visitors

17 profile views
  1. Froggy372

    Engine noise

    Hello, so my water pump started leaking outside the engine so I replaced it and the timing chain. Drove it for 2 months and one day it stalled while driving down the road. I did some research which led me to replacing the throttle body. I drove the car for 2 weeks with no issue. My son took the car and 30 minutes after he left, called me saying the car stalled and when he started it back up it was making a noise. So I hear a knocking noise coming from the back bank but cant tell if it's a connecting rod bearing, wrist bearing or hopefully just a loose rocker arm. It doesnt knock immediately but as I raise the rpms its gets louder but when I let it sit for a few days and restart it the noise is gone at first then starts coming back. It's not an obnoxious noise like a broken connecting rod. Any help in what direction to take here would be greatly appreciated.
  2. Froggy372

    Engine noise

    I have a 2007 Ford Edge SEL AWD 3.5/ 2 months ago I replaced the water pump and complete timing chain setup. About 2 weeks ago it stalled while I was driving down the road I got it home I did some research I replaced the throttle body the car ran great after that this past Monday it was being driven by my son he called me said the car stalled and when he restarted it it was making a funny knocking noise I got it home again did some more Diagnostics it gave me soft codes p0012 and p0022 both are camshaft position sensor codes so I purchased two new camshaft position sensors install them last night and I'm still getting a knock. I'm wondering if this point if the knocked is linked to connecting rod bearings. Any input would be greatly appreciated at this point
×