Jump to content

Emmyosodi

Edge Member
  • Content Count

    2
  • Joined

  • Last visited

About Emmyosodi

  • Rank
    New Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Emmyosodi

    Transmission Failure

    I have a 2013 Ford Edge with Ecoboost Engine. My transmission has failed twice this year alone. For each time it failed, I drove it for 4 month between the time it failed and the time it was fixed. Recently, I got a transmission from a scrapped Edge with low millage and fixed it on my vehicle. Upon fixing the transmission, during the first test drive, the spanner sign came on again and the vehicle started accelerating reluctantly. This was the issues the initial transmission was exhibiting before we decided to change it. Would appreciate any insight on these and possible solution on this persistent transmission failure. I trust I would get the solution on this forum. Regards.
  2. Emmyosodi

    Transmission Failure

    I have a 2013 Ford Edge with Ecoboost Engine. My transmission has failed twice this year alone. For each time it failed, I drove it for 4 month between the time it failed and the time it was fixed. Recently, I got a transmission from a scrapped Edge with low millage and fixed it on my vehicle. Upon fixing the transmission, during the first test drive, the spanner sign came on again and the vehicle started accelerating reluctantly. This was the issues the initial transmission was exhibiting before we decided to change it. Would appreciate any insight on these and possible solution on this persistent transmission failure. I trust I would get the solution on this forum. Regards.
×