Jump to content

Finisher42

Edge Member
  • Content Count

    3
  • Joined

  • Last visited

Everything posted by Finisher42

  1. My 2008 ford edge limited was leaking transmission fluid and spraying all over the engine compartment. I finally believe I found the root cause, a bad output shaft seal. The original seal was still in there and thus stuck after 13 yrs. So I tried every conventional method and ended up just breaking it out in pieces. Well me not being too bright thought there was a 2nd seal in there, and that really took a toll. I ended up drilling a small hole and inserting a screw to grab ahold of and thus pull the rest of the seal out🤦‍♂️🤦‍♂️. Little did I know the seal was already out and I just created a hole in the wall rite where the seal goes in. So, im leaking gear fluid and feel like a D.A. My question is can something like this be fixed, or is a new PTU in order for this kind of damage?? ( for some reason its not letting me post pictures of this. I will follow up and get some pictures uploaded. Thank you for any and all of your help. https://linksharing.samsungcloud.com/V5CbH3b9W7AN https://linksharing.samsungcloud.com/YiI0BNjRkIBN
  2. So, to you it looks like there is another seal in there that needs to comeout...? Thank you
  3. Long story short. I drilled a hole and inserted a screw in to what I thought was the output shaft seal on my 2008 edge limited. As it happens, the seal was already out, (broken out in pieces by me because it was stuck) I was replacing the front passenger side because of a leak. So now its leaking gear oil. Is there any way to plug something like this, or will the PTU have to be replaced?? Thank you. https://linksharing.samsungcloud.com/YiI0BNjRkIBN https://linksharing.samsungcloud.com/3gqqH1TWPZTN
×