Jump to content

rkierstead8

Edge Member
  • Content Count

    4
  • Joined

  • Last visited

Everything posted by rkierstead8

  1. rkierstead8

    2007 Edge slipping

    First of all, I want to say thank you for the wealth of information that is on this forum. I've been reading through some topics and I plan to continue doing so until I find a resolution. The reason for this post is to get some advice specific to my problem, so here goes. We've had our edge for about a year now and It has been leaking from the PTU for some time. (not sure how long). It is bad enough that we have a small puddle in the spot where we park in our garage. When I saw the spot I did some preliminary research and knew about some of the PTU issues with these cars, but now I think I'm at a cross roads where I HAVE to do something. We've had issues with a loud clunking noise when going into reverse and at time while accelerating onto the interstate. Yesterday her car wouldn't crank because the battery terminal was loose. I'm sure that is purely coincidental, but after I came and tightened it up for her and got her headed home, the transmission started to slip. This is especially bad around 20-25MPH and is fairly consistent. I've read about some sensor issues that may cause issues, but I'm lost on where to start. I know financially I can't spend thousands on a fix for this thing especially if I can't pin point the problem. That's where I'm hoping this community will help point me in the right direction. If the PTU is bad could it be causing the trans to slip? Are there known internal issues with the transmission that might cause something like this? Please help!
  2. rkierstead8

    2007 Edge slipping

    I called and they don't have one in stock, so I'm out of luck this weekend. I'm going to order the amazon ones and just deal with the slipping for a few days.
  3. rkierstead8

    2007 Edge slipping

    Any idea on the best place to find the sensors? I'd like to find them in a store so I can try to replace them this weekend, but that isn't looking likely. Edit: Still can't find a store, but can anyone clarify if these are the correct part numbers before I order them. It's hard to believe that they half the cost compared to the others that I have found. https://smile.amazon.com/gp/product/B072PPY6DH/ref=ox_sc_act_title_1?smid=A3B850ZGIPDG3A&psc=1 https://smile.amazon.com/gp/product/B071FF1L6H/ref=ox_sc_act_title_2?smid=A3B850ZGIPDG3A&psc=1
  4. rkierstead8

    2007 Edge slipping

    That is one of the things I was looking into akirby, so thanks for the suggestion. I don't have a "limp" mode going on... is it possible to have the slipping as a first sign of the problem? How could I recognize a failing PTU? since I know it's be leaking I'm scared I've messed it up.
×