Jump to content

jlchoitz

Edge Member
  • Content Count

    17
  • Joined

  • Last visited

About jlchoitz

  • Rank
    New Member
  1. I think I tripped the anti theft system while working on our Edge. I had the steering column out and forgot to plug in one connector and tried to start it. Now the anti theft light blinks fast and it won’t crank. I’ve tried unhooking the battery, tried both sets of keys, unlocking/locking with the fob, and locking/unlocking with the external keypad with no luck. Anyone else run into this before?
  2. I have a 2007 Edge, just replaced the AC evaporator. So had the whole dash out. Now the seat belt light won’t go out. I’ve been racking my brain trying to figure it out. There was one plug in that I couldn’t find a place to connect. It is in the center console. Can anyone tell me if there’s an unused plug or did I miss something. I’ll post I pic of it tomorrow. Thanks in advance!
  3. jlchoitz

    2007 Edge engine stalling

    Its definitely going into limp mode I disconnected the battery for a bit and it took right off for 30 seconds or so,and then went back into limp mode again. I ordered a throttle body, the local Ford service dept says this can all happen without any codes due to a bad throttle body. I ordered one, well see if that fixes it. If not, they say they can diagnose it for $119.
  4. jlchoitz

    2007 Edge engine stalling

    When you drive it, it wont go past 30 mph or so and wont shift right at all.
  5. jlchoitz

    2007 Edge engine stalling

    I think it is a timing issue, as in the VVT isnt working properly, the valves have started clattering now. Every time I start it again it seems to do something new LOL! Now I have to figure out why, I need to get this thing fixed and trade it in ASAP!
  6. jlchoitz

    2007 Edge engine stalling

    New update. It left me sitting on the side of the road today. I had it towed home. After sitting a while its back running again, but it wont develop very much power. I scanned it, but it still isnt throwing any codes.
  7. jlchoitz

    2007 Edge engine stalling

    It also has the issue where the transmission seems to be hunting around while on s slight incline. Its been doing it for a long time. Ive read of several things to try, any confirmed fixes, or could they be related?
  8. jlchoitz

    2007 Edge engine stalling

    Our Edge has recently started quitting. It seems to happen while slowing to a stop. Its only done it a few times now. It has new spark plugs, new air filter, and I cleaned the MAF. It isnt producing any codes. Where should I start looking?
  9. jlchoitz

    2007 Edge engine quits

    I dont remember what plugs I used, but I dont think they were Motorcraft. I think they mightve been Bosch. I also forgot to add that its not holding speed with cruise on very well either. When it quits, it doesnt want to start back up, it doesnt crank up right. But when it starts it seems to run ok. What are the symptoms of the purge valve failing?
  10. jlchoitz

    Timing Procedure?

    Everything I read said its very difficult and requires special tools. I called a friend that works on these, and he said I was over complicating it. I was actually surprised as to how simple it was to do.
  11. jlchoitz

    Timing Procedure?

    Everything I read said its very difficult and requires special tools. I called a friend that works on these, and he said I was over complicating it. I was actually surprised as to how simple it was to do.
  12. jlchoitz

    Timing Procedure?

    I did it on our Edge
  13. jlchoitz

    Miles Driven

    206,000 on our 2007 Edge
  14. jlchoitz

    2007 Edge engine quits

    Our Edge has 206,000 miles on it. I replaced the water pump, timing chain, and spark plugs about 700 miles ago. It was running fine until it started quitting. It seems to be quitting when coming to a stop/already stopped. I see there are several things such as throttle body or purge valve that could be causing it. It is throwing no codes. Any advice on where to start?
  15. jlchoitz

    Timing Procedure?

    Timing is actually a snap, there are marks on both the cam and crankshaft gears. Then all you have to do is line them up with the marks on the timing chain.
×