Jump to content

Custom Search

Welcome to the Ford Edge Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford Edge Forum - the largest Ford Edge forum discussion board on the web. You must register to create new topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Benefits of membership:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .and more!
Click here to signup now
 
Guest Message by DevFuse

Check out the Ford Edge ST Forum Here
 


Photo
- - - - -

Carrier Bearing (passenger side) 14 sport AWD leaking?? damage??


  • Please log in to reply
3 replies to this topic

#1 OFFLINE   OLD SARGE

OLD SARGE

    New Edge Member

  • Edge Member
  • 4 posts
  • Region:U.S. Southern Atlantic
  • Location:VIRGINIA
  • Edge's Year:2014

Posted 12 April 2018 - 02:20 PM

noticed this on an oil change...lots of grease on carrier bearing (?) (passenger side) .  dealer says it is not a problem..I'm not liking that answer much...opinions?  see attached picture...passenger wheel to the right in picture.

Attached Files









Lose this advertisement by becoming a member. Click here to create a free account.


#2 OFFLINE   JSchneid

JSchneid

    New Edge Member

  • Edge Member
  • 24 posts
  • Region:U.S. Southern Atlantic
  • Location:Louisville KY
  • Edge's Year:2016

Posted 12 April 2018 - 04:16 PM

I have seen the same thing on MACT Ford Edge facebookpage. Same response from dealers.https://www.facebook...3&theater&ifg=1



#3 OFFLINE   OLD SARGE

OLD SARGE

    New Edge Member

  • Edge Member
  • 4 posts
  • Region:U.S. Southern Atlantic
  • Location:VIRGINIA
  • Edge's Year:2014

Posted 12 April 2018 - 08:24 PM

JSchneid........I posted it on that page as well.  trying to find an answer



#4 OFFLINE   enigma-2

enigma-2

    Ford Edge Fanatic

  • Edge Member
  • 2,878 posts
  • Region:U.S. Great Lakes
  • Location:Indiana
  • Edge's Year:2009

Posted 12 April 2018 - 08:34 PM

Dealer don't feel it's a problem, so it must be monor. Next oil change ask the service rep "why" it's not a problem. Might also consider wiping it clean and see how much grease is actually leaking out. (Small amount could be normal over several 10,000's miles).




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users