Jump to content

DarrenLee55

Edge Member
  • Content Count

    2
  • Joined

  • Last visited

Everything posted by DarrenLee55

  1. 2007 ford egde having a transmission issue. Every once in a while it would have a slightly hard shift, ususally when accelerating fast to merge into traffic. But earlier this week it completely stopped working after stopping at a stop sign. Aftrer turning off the car for a few seconds I turned it back on and it engaged very rough. After that it wouldn't shift out of first gear. The engine RPMs were high and my speed was low. It felt as if it was slipping. If I kept my momentum up I could drive about 20-30, but if I had to stop I would have to turn the car off and wait a bit until I could continue on. The really odd thing was after sitting and waiting at a light about 2 blocks away from Aamco shop for a minute or so I turned the car back on and for those last two blocks the car acted normal. I was able to accelerate up to 50 and the car shifted normal. I pulled it into Aamco and later that day got a call that they couldn't get the car to move at all. They didn't find any codes, my fluid was at the proper level but smelled and looked burned (says the shop). They said they should do a rebuild. My question is what would cause these semi-intermittent issues where it would drive normal after sitting off for a while. I have the transmission apart down to the OSS and TSS sensors. (There were several small metal shavings attached to the TSS sensor when i pulled it out.) How far should I tear it down. What else should I be looking for? I would rather find the cause and fix it myself or at least verify it needs a rebuild before spending 3Gs on it. Thanks in advance
  2. DarrenLee55

    Something very wrong with my transmission.

    Thank you for the reply. I should note that when I drained the trans the fluid was a very dark red and did smell slightly burned. I could see a red tint when it was draining, but it looks very brown in the pan. I did not check the PTU yet. I am planning on replacing the sensors, but I wanted to take a look at the torque converter before I put it back together. How big of a pain is it to get it out. My alldata manual does not have the steps for this.
×