Jump to content

TheFloppyWeasel

Edge Member
  • Content Count

    29
  • Joined

  • Last visited

About TheFloppyWeasel

  • Rank
    New Member

Recent Profile Visitors

146 profile views
  1. I realized I had a bad brake light bulb, so when I went to get replacements, I decided to get LEDs instead of regular bulbs, and replaced both the left and right side top bulbs. the issue I found I have is if I’m holding down the brake pedal and let off, the brake lights are delayed in turning off, rather than immediately turning off when I release the brakes. If I just tap the brakes really quick, the brake lights more or less match and then off immediately. The issue only happens when I’m engaging the brakes longer than just a tap. any ideas? Was hoping it was just plug and play.
  2. TheFloppyWeasel

    Remote start sometimes doesn’t work

    I was somewhat thinking the same thing. I would hope the battery wouldn’t already be going bad. I just had it replaced over the summer.
  3. For some reason lately, the remote start will turn the engine over maybe once but not actually start it. When I get in and press the start button it starts fine. Any ideas? I’m not sure why it never gives me an issue when I press the button, but occasionally acts up when using remote start.
  4. TheFloppyWeasel

    Console lighting

    Ah, at least I feel a little less dumb now haha. I need to find another edge and open it up to trace the wires to figure out where they go.
  5. TheFloppyWeasel

    Console lighting

    Yeah, I have no idea what to do with that area. I put my wallet there one day and spent 30 minutes trying to find it later because I forgot I put it there. The wiring color does match that of the wires going to the cup holders. I just have to figure out where it hooks in.
  6. TheFloppyWeasel

    Console lighting

    I traced the wires from the back cup holder to the front one, then to the map pocket led. But I stopped once I got to the cut wires and started trying to figure out where they were supposed to go. I really shouldve traced them back from where they were cut. I can do that today probably. So, I noticed from the diagram above that theres supposed to be an led for the map pocket. I assume thats the little open area in the center console towards the bottom/back kind of near the passengers side cigarette outlet? I looked back there to verify there was an led there and guess what, that one also doesnt work. Im assuming theyre related. The light inside of the center console/storage area works.
  7. TheFloppyWeasel

    Console lighting

    So, were thinking those cut wires are part of the ambient lighting in the cup holders? I didnt see anywhere they might have been cut from though when I was looking. Both led modules had wires going to them.
  8. TheFloppyWeasel

    Console lighting

    So I got one problem solved. The light that clips into the plastic for the gear lighting had broken off from the previous owner. I managed to secure it back in place, but I cant figure out the cup holder lighting issue. Everything seemed to be plugged in as it should. Didnt notice any broken wires in that part of the harness. Not sure what the next step is other than testing that the wires have power. I did notice some cut wires towards the bottom of the console. Any idea what these go to?
  9. TheFloppyWeasel

    Console lighting

    Haha no worries. Ill have to get in there and check it out. Hopefully thats the case. Can the lights themselves be replaced if needed?
  10. TheFloppyWeasel

    Console lighting

    lol, yeah its turned on and it works as it should everywhere else
  11. TheFloppyWeasel

    Console lighting

    The ambient lighting in the cup holders and the gear letters/numbers beside the shifter apparently are supposed to illuminate, but mine dont.
  12. TheFloppyWeasel

    Console lighting

    So it seems I have some lights not working then. How hard is it to replace the lights or do you have to replace more than just the lights?
  13. Maybe this question has been asked before, but are the gear indicator letters and numbers by the shifter supposed to be lit up? What about rings in the cup holders? If so mine dont work. How easy is it to fix if so? 2011 edge sport
  14. TheFloppyWeasel

    Brakes briefly turned to mashed potatoes

    Haha thats what Im worried about...if it happens again. Im about to head home, so well see So I think I may be in luck. Going back to akirbys first response, it could have been a slick spot on the road. As I was driving past the location where the brakes went wonky, I noticed a rather large spot of what looked to be some sort of oil, right where I would have been merging. Im thinking this is what caused the abs to kick in.
  15. TheFloppyWeasel

    Brakes briefly turned to mashed potatoes

    The only thing here though is that it happened as I was merging into the turn lane and coming to a stop at lower mph. I hadnt started the left turn yet. Maybe that doesnt matter? Would that be a common thing though? Its never done that before and Ive chucked it into a hard turn before while braking hard. Im trying to decide if I need to send it to the dealer or at least have a couple of specific things I can check on myself.
×