Jump to content

vtchopperdude

Edge Member
  • Content Count

    46
  • Joined

  • Last visited

  • Days Won

    1

About vtchopperdude

  • Rank
    New Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. vtchopperdude

    What have you done to/with your Edge/MKX today?

    They just didn't hook it back up! I was able to see water dripping out of the tube behind the center console onto the tunnel, and it was just pooling in the floorboards. It was as easy as reattaching it once I figured out that was the problem. But because the carpet and sound deadening material soaked up the water, it took 4 hours of my wife driving on a trip for me to realize that water was pooling. Long story short, they dried the carpets out, and detailed the inside. All is well, so far......
  2. vtchopperdude

    What have you done to/with your Edge/MKX today?

    Welp, finally got the car back after dropping it off to fix the standing water issue in the floorboards. Interestingly enough, the center console USB starting giving the "excess power draw" warning following the water in the floorboards incident. The dealer didn't remove the carpet, but used some sort of heating element to dry everything out in the car. They also replaced the USB port in the center console, and detailed it. Hopefully the saga of returning the the dealer for poor repairs is over!
  3. vtchopperdude

    What have you done to/with your Edge/MKX today?

    Wow!!!!! F! M! L! We finally got the water pump issue worked out! Pump seized, shredded the serpentine belt, and caused some power steering issues. That got all squared away after 2 visits to the dealer. Well, remember how I mentioned that we had issues with no warm air several months back, and it took them 2 weeks to diagnosis it as a bad valve, which subsequently caused debris to get into the heater core. Well, they had to completely remove the dash, and in doing so broke multiple trim pieces. They replaced those at cost (thankfully). Now the real kicker! Apparently they didn’t reinstall the AC drain tube properly, so all the condensation was leaking directly to the floorboards. Well, considering my wife was only driving it a few miles back and forth to work, it never dripped enough to be noticeable. Well...she drove down to FL on a 4 hour trip, and when she arrived and got out of the car, she noticed standing water in the passenger side floorboard area. OMG! I thought it was the heater core that was just replaced. I did some more investigating in the hotel parking lot, and after watching some YouTube videos, found the drain tube behind the dash and it was not connected. So, for 4 hours all that AC condensation was just dripping into the floorboards. Standing water!!!! What the f**k!!! Do I even take it back to this dealership and let them mess something else up? What are my options? I’m pretty sure the carpet will need to be replaced because it is drenched on both driver and passenger side!
  4. vtchopperdude

    What have you done to/with your Edge/MKX today?

    I'm about at wits end with this dealership! What makes it really crappy is that their customer service is EXCELLENT!!!! I mean EXCELLENT!!! Their communication is great, their hospitality is great, their attitude is great, and the service desk guy I deal with is great!!! Buuuuuuuuuuuutttt, the service is HORRIBLE!!! The worst I've ever seen!!! And I drive 3 Ford vehicles (F150, Edge, and Mustang). My whole family is a Ford family. My grandfather worked on the assembly line installing steering columns for over 30 years. My grandma still receives a Ford pension check every month and my grandfather passed about over 20 years ago. I reallllly want to put faith in this shop (only Ford dealer in town) that they can fix it right this time....but 5 times!!!! What the heck!!!!
  5. vtchopperdude

    What have you done to/with your Edge/MKX today?

    Well F**K MY LIFE!!!!!! Got a call from the dealer. Water pump replaced and car is ready. Go to pick it up. We get about 5 minutes down the road and my wife is flashing the lights at me in the rearview mirror. Well........I walk up to the car and I smell something burning. The dash has about 5 different warnings...battery, overheating, power steering, check coolant, and something else. I pop the hood, and the smell of burning rubber hits me in the face. The serpentine belt is shredded, and the coolant reservoir tank is overflowing. As I said...F**K MY LIFE!!!!!! This is the 5th time we have taken the car back for them to fix their mistakes!!! Granted, they fix it on their dime every time, it's still super FRUSTRATING to waste my time to keep taking it back for improper repairs!!! So ya, my Friday just got sh*t on!!!
  6. vtchopperdude

    Add a Shelf To Your Center Console

    Cooool!
  7. vtchopperdude

    What have you done to/with your Edge/MKX today?

    And ya it's a great car! It's my wife's daily and we use it for traveling! It just seems like all these problems are starting to pop up after we hit 100k.
  8. vtchopperdude

    What have you done to/with your Edge/MKX today?

    Ya, we are the 2nd owner and treat it like a new car. Purchased with 72k about 2 years ago. It has 102k on it now. Well, after we had the heater core replaced about 6 weeks ago (whole nother story there!!), I noticed a burning smell after getting out of the car. I thought maybe the new coolant they put in was just smelling funny during breakin of the new heater core (is that even a thing??). Well, I came home to huge stain on the driveway a few days ago. I pulled the plastic belly pan and the sound proofing material was soaked and lots of coolant residue on the plastic. I suspected they messed something up with the heater core replacement, but noticed the leak was coming from around the pulley area. The part they replaced for the heater core job was on the opposite side of the engine. So, long story short, big puddle on the driveway; took it back to Ford this morning; they called said water pump is going out. It leaked about a 1/2 gallon of coolant before I noticed it because that huge belly pan soaked up alot of the leakage. They quoted me around $700 total. Seems pretty steep for a water pump, but I'm slammed at work so I am just biting the bullet and having the dealer replace it. After all the crap that has gone on with the car, it makes sense for them to do it because they warranty the work for 2 years.
  9. vtchopperdude

    What have you done to/with your Edge/MKX today?

    water pump went t*ts up on me...
  10. vtchopperdude

    2014 Edge Limited No Heat

    Yep, dealership called and said it was the water pump. I find it interesting that the water pump started leaking shortly after they replaced the heater core...coincidence, or not?!?!
  11. vtchopperdude

    2014 Edge Limited No Heat

    So, it is dripping down from the passenger side of the engine, where the pulleys are. That valve you reference is on the other side of the engine, so it's not the issue. Is the water pump on these engines internal?? All I know is that I've NEVER had to even top off the coolant since owning this car for 3 years. But, since getting the car back after the repairs, and less than 100 miles, it has lost almost a gallon of coolant. Something tells me that the repair was not done correctly, or when they reassembled something, they caused damage to something else.
  12. vtchopperdude

    2014 Edge Limited No Heat

    102k currently. Bought it with 72k from the dealership where the original owner traded it in. It belonged to an older lady, and all maintenance was done at the dealership. No slime buildup that I can tell. Orange coolant prior to heater core change. I'm assuming they replaced with the same Ford orange coolant.
  13. vtchopperdude

    2014 Edge Limited No Heat

    Well that didn’t last long...!!! Only put about 100 miles on it due to COVID telework. Came home today to a big stain on the driveway! Looked under car and the belly pan is soaked in coolant. I pop the hood and there is NOTHING in the radiator overflow!
  14. vtchopperdude

    2014 Edge Limited No Heat

    Well it's been about 6 weeks and no issues. It sucks that the design flaw of a $100 part causes close to $2,000 in damage repairs. Oh well, my wife loves the car and it's great for traveling, and we own the car, so fixing was the right choice! Plus, they broke the touch screen radio fascia on reinstall, so they replaced that too, which was around $500 I believe! Brand new touch screen control!
×