Jump to content

2011 Edge Navigation

Recommended Posts

Today I tried to enter Merrill Lynch into my nav system. It wasn't listed under Financial Institutions so I decided to spell it. The system wouldn't let me spell the entire name so I tried to enter the phone number. Same thing. The phone number wasn't accepted. Then I tried the same thing with Office Max and got the same result.


Has anybody else had this experience?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...