Jump to content

Custom Search

Welcome to the Ford Edge Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford Edge Forum - the largest Ford Edge forum discussion board on the web. You must register to create new topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Benefits of membership:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .and more!
Click here to signup now
 
Guest Message by DevFuse

The Ford Edge ST Has Been Unveiled.  More here.


Photo
- - - - -

2011 Edge valve cover


  • Please log in to reply
27 replies to this topic

#21 OFFLINE   Gbczyk84

Gbczyk84

    New Edge Member

  • Edge Member
  • 16 posts
  • Region:U.S. Northern Plains
  • Location:IL
  • Edge's Year:2011

Posted 08 November 2017 - 08:49 PM

Is it just me? I don't see where the difference is between the old & new covers!

Since I still have oil in the air filter 2 months since the replacement, there may not be a difference between old and new.
  • WWWPerfA_ZN0W likes this







Lose this advertisement by becoming a member. Click here to create a free account.


#22 OFFLINE   WWWPerfA_ZN0W

WWWPerfA_ZN0W

    Ford Edge Legal Resident

  • Edge Platinum Member
  • 8,392 posts
  • Region:U.S. Northeast
  • Location:Maryland
  • Edge's Year:Decline

Posted 08 November 2017 - 10:52 PM

well, that's not good!  have you replaced the pcv valve yet?



#23 OFFLINE   omar302

omar302

    Ford Edge Addict

  • Edge Platinum Member
  • 1,715 posts
  • Region:Middle East
  • Location:Qatar
  • Edge's Year:2011

Posted 08 November 2017 - 11:48 PM

Since I still have oil in the air filter 2 months since the replacement, there may not be a difference between old and new.

 

On my MKX, before the replacement cover, I saw oil on the intake tube up to the throttle body, though did not see it on the filter itself. I had the cover replaced at least a 18 months ago, and recently I checked & still no oil was present in the intake tube or throttle body.

 

When you have the valve cover replaced, did you clean the whole intake tube? Maybe there was oil residue.


  • WWWPerfA_ZN0W likes this

#24 OFFLINE   macbwt

macbwt

    Ford Edge Fanatic

  • Edge Platinum Member
  • 2,624 posts
  • Region:U.S. Mississippi Valley
  • Location:Davenport Iowa
  • Edge's Year:2011

Posted 09 November 2017 - 06:26 AM

I plan on replacing my valve cover and will aim to see if the oil consumption over 10K miles or 200hr of use reduces.


  • WWWPerfA_ZN0W and PaulSchott like this

#25 OFFLINE   omar302

omar302

    Ford Edge Addict

  • Edge Platinum Member
  • 1,715 posts
  • Region:Middle East
  • Location:Qatar
  • Edge's Year:2011

Posted 09 November 2017 - 09:49 AM

I plan on replacing my valve cover and will aim to see if the oil consumption over 10K miles or 200hr of use reduces.


What is your current oil consumption?

#26 OFFLINE   Gbczyk84

Gbczyk84

    New Edge Member

  • Edge Member
  • 16 posts
  • Region:U.S. Northern Plains
  • Location:IL
  • Edge's Year:2011

Posted 09 November 2017 - 09:31 PM

well, that's not good!  have you replaced the pcv valve yet?


I did not, when i did the spark plugs at 75K it was changed, valve cover around 85K so didnt find it necessary to do. I did swap a new one last night, the old one was pretty drenched with oil.

#27 OFFLINE   Gbczyk84

Gbczyk84

    New Edge Member

  • Edge Member
  • 16 posts
  • Region:U.S. Northern Plains
  • Location:IL
  • Edge's Year:2011

Posted 09 November 2017 - 09:32 PM

 
On my MKX, before the replacement cover, I saw oil on the intake tube up to the throttle body, though did not see it on the filter itself. I had the cover replaced at least a 18 months ago, and recently I checked & still no oil was present in the intake tube or throttle body.
 
When you have the valve cover replaced, did you clean the whole intake tube? Maybe there was oil residue.


Yes had that tube cleaned, also removed the throttle body at the time for a proper clean from both sides.

#28 OFFLINE   macbwt

macbwt

    Ford Edge Fanatic

  • Edge Platinum Member
  • 2,624 posts
  • Region:U.S. Mississippi Valley
  • Location:Davenport Iowa
  • Edge's Year:2011

Posted 10 November 2017 - 11:44 PM

What is your current oil consumption?

1/2 to 3/4 quart over 200 hours of engine time


  • omar302 likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users