Jump to content

my2k2zx2

Edge Member
  • Content Count

    7
  • Joined

  • Last visited

  • Days Won

    1

About my2k2zx2

  • Rank
    New Member
  1. my2k2zx2

    PTU fluid change issues..

    I was using this guide and ours had the exact setup. Just could not get the drain plugs to budge.
  2. my2k2zx2

    PTU fluid change issues..

    I tried to change the PTU fluid on our 2016 today but I could not get either drain plug to budge with my basic 3/8 ratchet. I'm hoping to get it loose after I get a longer ratchet.
  3. my2k2zx2

    Remote Start stopped working ?

    We have an aftermarket (fortin) remote start that uses the factory fob. We go lock-unlock-lock and the vehile starts up. We did have a CEL come on last year and the remote start would not work until the issue was fixed and the code was cleared.
  4. H7 does fit, put one in our 2016 earlier this year. I removed the air filter box lid and moved the ground wire out of the way to install. I did not have to remove the cowling to fit. The battery tray has threaded holes for 3 different sized batteries, but is not mentioned in any documentation. If you look up the battery on parts.ford.com it shows 90T5, H6 and H7 as compatible options. I found that after the parts store in town only showed the stock battery size and it was special order only. https://imgur.com/EFRbtXS
  5. Last week I was getting a P0036 code, so I replaced the oxygen sensor. This week I'm now getting a P0330 code, knock sensor 2. Is this something that I can fix on my own or would I be better off taking it in to be replaced? Or is there something else that can be done to take care of this issue?
  6. my2k2zx2

    2016 2.0L - PTU drain and fill plugs?

    Yeah, I think that's what I'm looking at for the drain. How easy is it to remove the intake tube? Or would it be enough to cover things with foil while I'm doing the drain/refill? https://imgur.com/GEndJjW
  7. I'm planning on changing the PTU fluid. What I'm seeing doesn't look like anything I've seen on other Edge PTU. The ones that I've seen had the fill and drain on the same side. I think mine has the fill on the side and the drain on the bottom and both appear to need a T50 to remove. Would that be the correct fill & drain plugs?
×