Jump to content

Dasher21591

Edge Member
  • Content Count

    44
  • Joined

  • Last visited

About Dasher21591

  • Rank
    New Member

Recent Profile Visitors

90 profile views
  1. It's a 2011 Edge Limited AWD I don't have a pic of the Forscan because that's the issue not sure what mod it is. Would be nice to figure this out. When I first looked into it I was concerned about it overheating because the fans never came on. I sense have replaced the fan module and they run when I turn on the A/C so hopefully they will run in warmer weather. With the idiot symbol all I know is if it's warmed up or not and where it normally rides. I just really don't know what temp it is. Like I said in my first post there is youtube videos of this being change on some Fords and I've tried what they did but they were not the Edge and maybe the wrong year. Any help with this would be greatly appreciate. now let's see if the pic will send
  2. I purchased it on ebay. They had some nice leather as well. item ID 173908681770 I to am concerned about putting it on. I believe it will require some contact adhesive witch is fine my concerns are taking the old one off without breaking clips or whatever is holding it on. I will try to send two photo's but I've had issues getting my attachments to load on to this forum. Well see
  3. I have just bought a imitation leather tan that matches my interior perfectly. It looks like I got to take the top off my armrest and your glue it on there. I just haven’t been able to figure out how I take the top off the consul cover without destroying some clips. The imitation leather I purchased seems to be good quality, nice sewing job and they did have real leather as well but what I bought was 19 bucks.
×