Jump to content
Sign in to follow this  
2016_Titanium

2016 Edge, Sync Version 2.0 Apple Car Play

Recommended Posts

So....picked up my new 2016 Edge yesterday and notice no Apple Car Play.

 

Currently have Sync version 2.0 which is Car Play compatible but according to what I am seeing I need to upgrade the USB hub in the console area.

 

Ordered part # HC3Z-19A387-B from Sweeney Ford and picked up a trim removal set from Amazon for $6. Hope to tackle the replacement this weekend, will let you know my results.

 

Share this post


Link to post
Share on other sites

Dont try to remove the hub from the front. Remove the trim piece on the right side of the cubby and attack it from the back. Going at it from the front is a frustrating battle.

Share this post


Link to post
Share on other sites

Thanks, is it really that hard from the front if you have a trim removal tool?

 

If I attack from the back, anything special to know about getting the hub out?

Share this post


Link to post
Share on other sites

Thanks, is it really that hard from the front if you have a trim removal tool?

 

If I attack from the back, anything special to know about getting the hub out?

 

I had trim removal tools and followed the steps others had used to pull the hub out from the front. It was a bear. Undoing it from behind (after removing some of the center console trim pieces) seems to be the smoother/easier way to go. Attached is an image of the old hub after I finally got it out (using needle nosed pliers).

post-44315-0-55100900-1482003924_thumb.jpg
  • Like 1

Share this post


Link to post
Share on other sites

Success!!!

 

One attempt to remove from the front and said.....no way this will be easy.

 

Removed trim from passenger side center console, really easy by just pulling and popping the clips out.

 

Then removed the rear cover to the center console behind the USB port for full access.

 

Felt for the tabs and squeezed my fingers in there and pressed the tabs down while pushing on the back and it slid right out.

 

Tied off the wires with a couple pieces of fishing line so they didn't drop back in. Each connector for the hub had a small clip, removed the old and connected the new. Plugged in my phone and Apple Car Play came right up, accepted and looks beautiful.

 

All in all really easy to swap out, maybe 20 minutes tops.

 

 

 

 

post-44967-0-08582100-1486834976_thumb.jpg

Share this post


Link to post
Share on other sites

hi, I also have a 2016 titanium and was disappointed to learn carplay was not available. I updated my sync3 to v2.0 and I have been reading extensively about the hub replacement.

 

the hub I was going to order is part number HC3Z 19A387-B supposedly because this is lighted blue to match the edge lighting. I went to the dealer today and was going to buy it untl the service tech told me I was wasting my money. he said he looked it up and found nothing about the hub replacement.

 

since it has obviously worked for the OP'ster (and others from what I have read) i'm going to order the part and see what happens.

 

I even went to the Ford Sync web site and talked on-line with a rep who told me I needed a "hardware upgrade". When I asked for the part number, they said they didn't have it. ????

 

update: just ordered it from the dealer, will be here in the morning. wish me luck!

Edited by mga

Share this post


Link to post
Share on other sites

hi, I also have a 2016 titanium and was disappointed to learn carplay was not available. I updated my sync3 to v2.0 and I have been reading extensively about the hub replacement.

 

the hub I was going to order is part number HC3Z 19A387-B supposedly because this is lighted blue to match the edge lighting. I went to the dealer today and was going to buy it untl the service tech told me I was wasting my money. he said he looked it up and found nothing about the hub replacement.

 

since it has obviously worked for the OP'ster (and others from what I have read) i'm going to order the part and see what happens.

 

I even went to the Ford Sync web site and talked on-line with a rep who told me I needed a "hardware upgrade". When I asked for the part number, they said they didn't have it. ????

 

update: just ordered it from the dealer, will be here in the morning. wish me luck!

 

That is the correct part w/ the blue accent lighting.

 

Once you have the install completed start the car and let Sync load completely before plugging in your phone, after that the Car Play accept screen should pop right up.

 

I also put the car in neutral with the parking brake on to have more room to work with.

Share this post


Link to post
Share on other sites

thanks!!

 

i'll report back when I get it installed.

 

and I should go show the dealership tech who told me I was wasting my money.

Edited by mga

Share this post


Link to post
Share on other sites

one more question: if you're using maps on CarPlay, and you switch over to the car's radio, for example, will the maps still be running in the background with voice directions as well?

 

or, does switching back to the sync2's main menu cancel CarPlay? I'll find out soon enough but I was just wondering about that.

 

 

update:

 

installed in about 20 minutes and worked!! I was nervous removing the plastic in the cold but nothing broke or cracked. (whew)

 

wife is happy.

 

thanks to you guys in this forum!!!

Edited by mga

Share this post


Link to post
Share on other sites

If I recall, the voice nav from the Car Play map will still broadcast if you switch back to the Ford radio.

  • Like 1

Share this post


Link to post
Share on other sites

Success!!!

 

One attempt to remove from the front and said.....no way this will be easy.

 

Removed trim from passenger side center console, really easy by just pulling and popping the clips out.

 

Then removed the rear cover to the center console behind the USB port for full access.

 

Felt for the tabs and squeezed my fingers in there and pressed the tabs down while pushing on the back and it slid right out.

 

Tied off the wires with a couple pieces of fishing line so they didn't drop back in. Each connector for the hub had a small clip, removed the old and connected the new. Plugged in my phone and Apple Car Play came right up, accepted and looks beautiful.

 

All in all really easy to swap out, maybe 20 minutes tops.

 

 

 

Help me here.

 

I removed the two trim pieces recommended (side clipped on piece and top part of rear of cubby). While I can easily press the single clip on the passenger side and the top clip of the installed usb hub, THERE IS NO WAY MY FINGERS WILL FIT up beside the drivers side (two clips) in order to push them in. Fingers half my size would not fit. How in the heck did you guys get the two drivers side clips pressed in order to "pop" it out? I just spent an hour trying and now I am a sweaty mess with a bunch of pieces and tools on the driver side floor.

 

Gonna watch some Cindy Crosby and hope one of you are able to tell me the secret.

 

Ugh. Thanks.

 

Jim

 

Edit: I guess its is Nashville vs Anaheim so no Cindy (good).

Edited by aloyouis

Share this post


Link to post
Share on other sites

 

Success!!!

 

One attempt to remove from the front and said.....no way this will be easy.

 

Removed trim from passenger side center console, really easy by just pulling and popping the clips out.

 

Then removed the rear cover to the center console behind the USB port for full access.

 

Felt for the tabs and squeezed my fingers in there and pressed the tabs down while pushing on the back and it slid right out.

 

Tied off the wires with a couple pieces of fishing line so they didn't drop back in. Each connector for the hub had a small clip, removed the old and connected the new. Plugged in my phone and Apple Car Play came right up, accepted and looks beautiful.

 

All in all really easy to swap out, maybe 20 minutes tops.

 

 

 

Help me here.

 

I removed the two trim pieces recommended (side clipped on piece and top part of rear of cubby). While I can easily press the single clip on the passenger side and the top clip of the installed usb hub, THERE IS NO WAY MY FINGERS WILL FIT up beside the drivers side (two clips) in order to push them in. Fingers half my size would not fit. How in the heck did you guys get the two drivers side clips pressed in order to "pop" it out? I just spent an hour trying and now I am a sweaty mess with a bunch of pieces and tools on the driver side floor.

 

Gonna watch some Cindy Crosby and hope one of you are able to tell me the secret.

 

Ugh. Thanks.

 

Jim

 

Edit: I guess its is Nashville vs Anaheim so no Cindy (good).

Okay.....

 

Brute force. I got up again, grabbed a roofing hammer and smashed the crap out of the lower console. Damn thing popped out alright.

 

 

Just kidding. I did use the roofing hammer and brute force. I was able to get both the flat pry end of the hammer and some folded paper towel under the drivers side of the usb hub from the top and pried it out. When it finally gave it made the same noise a rock'em sock'em robot game made when you knocked his block off. The paper towel protected the plastic.

 

The rest was cake and pie. Plugged it in and presto - CarPlay. The maps are sooooo much better!!!!

Share this post


Link to post
Share on other sites

Hey all, can you help me out in providing some idea on how to "Then removed the rear cover to the center console behind the USB port for full access"

 

Never mind, found an answer in the middle of the thread

http://www.fordedgeforum.com/topic/21394-sync-3-and-carplayandroid-auto-information/page-14?hl=center

 

Thanks!

Edited by unpluggedk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×