Jump to content
Ford Edge Forum
Barry

Lower Control Arm torque settings 2-rear bolts

Recommended Posts

Hi,

Just installed new lower control arms and struts on both sides of my 2008 for Edge. Torqued all bolts under load to settings in picture below but every time I go over a bump it sounds like my suspension is going to fall out loud metal on metal banging, what have I done wrong. any help would be much appreciated.

 

fordedge.JPG

Edited by Barry
spelling

Share this post


Link to post
Share on other sites

this video is ok,  but the torque settings for the two rear lower control arm have to be wrong.

see image below,

image.png.85b549adae0715c0bd0e564143fd0dd3.png

Share this post


Link to post
Share on other sites
On 8/23/2019 at 9:14 AM, Barry said:

Hi,

Just installed new lower control arms and struts on both sides of my 2008 for Edge. Torqued all bolts under load to settings in picture below but every time I go over a bump it sounds like my suspension is going to fall out loud metal on metal banging, what have I done wrong. any help would be much appreciated.

 

fordedge.JPG

Hi, any update on fix. I just replace left lower control arm and also hear some creaking sounds. torqued using same specs as shown on pic other than sway bar link, which i'm unable to torque due to not having tool. Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×