Jump to content
Daosdao

TPMS Receiver Module Location? Ford Edge 2008

Recommended Posts

Sometimes I have 'sensor pressure fault' . Replaced tire sensors 3 times !

 

I watched for sensors values and RR sensor didn't update. 

 

As far as I know tpms receiver located inner Smart Junction box ?

Where TPMS antenna located ?

Share this post


Link to post
Share on other sites
12 hours ago, Daosdao said:

Where TPMS antenna located ?


You'll get a more accurate answer if you include the year of your Edge in a message.  So you don't have to remember it each time, go to your profile page and fill out the Sig area to include year/model etc.

I can't help with the antenna location but this 'might' help with programming if you have a Gen2 Edge.
1. Press the Start button (don't start the engine)
2. Press the hazard warning button six times on/off/on/off/on/off  Your horn will sound.
3. Work your way clockwise around the car starting with the left front, slowly letting air out of each tire until the horn sounds.  A single beep means that corner is programmed.  A double beep means there's a problem, try it again.  If there's another fail there's likely an issue with the wheel sensor.
4. After you've done the last (left rear) corner check your display.  It should say something like TPMS programming complete.
5. Hit the Start button again to turn everything off.  Air your tires back up to the spec posted on the driver's door sill.
6. Go for a short drive with the tire display showing on the dash.  You should now have pressures displayed and (bonus) they'll be at the correct corner of the car. 

Tuck this away for the next time you rotate tires to keep the display accurate (so front pressures don't show on the rear etc).

 

Edited by Gadgetjq

Share this post


Link to post
Share on other sites

Thanks for replying.

 

2008 Ford Edge AWD SEL

 

I had the issue with TPMS with error message. I replaced sensors 3 times. BTW I see the issue is not in sensors.

I use forscan app +OBD reader to read all PIDs for tire pressure sensors. All sensors values (LR, LF, RF) updated, but RR sensor value (located most distance from receiver) updated very seldom. If RR doesn't pull values in 20 mins SJB considers it as fault.

 

I suspected TPMS receiver. I know it is located in Smart Junction Box. I guess the TPMS antenna for this model is inside  SJB. Is it correct ?

 

Now I have another issue:  Poor Key Fob Range. Before I could lock/unlock in distance ~20 meters. Now I can do it only in 1-2 meter. I replaced a battery in key, but the same result.

Are there some workarounds to fix it ?

 

Should I replace SJB in this case ? According wire diagram TPMS and RKE use the same antenna (315 MHZ) 

Check wires, connections, fuses ?

 

 

 

 

 

Share this post


Link to post
Share on other sites

I have spare SJB from another Ford Edge 2008. I dissembled it and I guess it is tpms antenna:

 

 

 

image.png

Edited by Daosdao

Share this post


Link to post
Share on other sites

Solved.

The culprit was DC-DC for dashcam.

 

image.png.92b785434f4580b13e42f42fbf52046e.png

 

Ford Edge 1 generation has common 315 MHz antenna for TPMS and Key Fob and very sensitive to Electro-Magnetic Interference

 

Now  Key Fob distance is 20 meters and TPMS reads all tire sensors without issues.

Share this post


Link to post
Share on other sites

I’m having the exact same problems as Daosdao with the TPMS sensors and my key fob. My husband and I are wondering if it could be my using the Sync bluetooth feature for hands free talking on my cell phone? That’s really the only thing extra being used in my car. Also, could someone please tell me where the TPMS Key Fob module is located on my ‘08 Edge? Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×