Jump to content

Custom Search

Welcome to the Ford Edge Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford Edge Forum - the largest Ford Edge forum discussion board on the web. You must register to create new topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Benefits of membership:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .and more!
Click here to signup now
 
Guest Message by DevFuse

The official Ford authorized Ford Edge Registry is now live. More here!


Photo
- - - - -

Resume on the cruise control is not working

cruise

  • Please log in to reply
7 replies to this topic

#1 OFFLINE   Dandy

Dandy

    New Edge Member

  • Edge Member
  • 2 posts
  • Region:Decline
  • Location:Clarinda, IA
  • Edge's Year:Decline

Posted 14 July 2017 - 10:40 PM

I have had the cruise control switch on the steering wheel replaced twice and the resume button still will not work must of the time. Odd thing the volume control switch on the steering wheel does not work at the same time. I told the service department this but all the dis wa replace the cruise control switch.







Lose this advertisement by becoming a member. Click here to create a free account.


#2 OFFLINE   jmr061

jmr061

    New Edge Member

  • Edge Member
  • 265 posts
  • Region:U.S. Great Lakes
  • Location:Upper Midwest
  • Edge's Year:2016

Posted 14 July 2017 - 10:57 PM

It would be helpful to know the year of your vehicle.



#3 OFFLINE   enigma-2

enigma-2

    Ford Edge Fanatic

  • Edge Member
  • 2,332 posts
  • Region:U.S. Great Lakes
  • Location:Indiana
  • Edge's Year:2009

Posted 15 July 2017 - 12:15 AM

I would check the steering wheel clockspring.
  • WWWPerfA_ZN0W and macbwt like this

#4 OFFLINE   enigma-2

enigma-2

    Ford Edge Fanatic

  • Edge Member
  • 2,332 posts
  • Region:U.S. Great Lakes
  • Location:Indiana
  • Edge's Year:2009

Posted 15 July 2017 - 01:12 AM

Ran across a Youtube video which states that the most common cause of cruise control failure (90% of the time) is a failure of the secondary redundant pressure switch. Apparently they fail open and does not allow the cruse to engage.



#5 OFFLINE   akirby

akirby

    Ford Edge Legal Resident

  • Moderator
  • 9,969 posts

Posted 15 July 2017 - 07:48 AM

Since the radio controls are also affected I would second the clockspring as the likely culprit.
  • WWWPerfA_ZN0W and macbwt like this

#6 OFFLINE   macbwt

macbwt

    Ford Edge Fanatic

  • Edge Platinum Member
  • 2,492 posts
  • Region:U.S. Mississippi Valley
  • Location:Davenport Iowa
  • Edge's Year:2011

Posted 15 July 2017 - 10:50 AM

3X on the clock spring


Edited by macbwt, 15 July 2017 - 10:50 AM.

  • WWWPerfA_ZN0W likes this

#7 OFFLINE   Dandy

Dandy

    New Edge Member

  • Edge Member
  • 2 posts
  • Region:Decline
  • Location:Clarinda, IA
  • Edge's Year:Decline

Posted 15 July 2017 - 02:02 PM

It is a 2013 Limited. Thanks

#8 OFFLINE   jmr061

jmr061

    New Edge Member

  • Edge Member
  • 265 posts
  • Region:U.S. Great Lakes
  • Location:Upper Midwest
  • Edge's Year:2016

Posted 15 July 2017 - 04:49 PM

The volume and resume run through the same wire to the clockspring to the SCCM.  Considering you are having issues with both, its not the button pack.  Its something after the two meet which is before the clockspring.  So wiring->clockspring->wiring->SCCM.  Something in that chain is bad.


  • WWWPerfA_ZN0W likes this





Also tagged with one or more of these keywords: cruise

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users