Jump to content
Ford Edge Forum
Sign in to follow this  
jroc2004

Blend doors

Recommended Posts

Have 2009 edge, dual climate eatc.  No heat on drivers side, heat only on passenger side.  Drivers side and passenger side actuators work.  Mode actuator works, and recirc actuator works.  No codes from onboard eatc test, and no codes from obd scan.  A/c works on both sides.  Full coolant, no leaks.  

 

Do the blend door actuators move one door or 2 doors each?  

 

Malfunctioning eatc? 

 

 

Share this post


Link to post
Share on other sites

So, in case anyone was wondering, my heater core was partially clogged.  Flushed it out with a product called irontite thoroflush.  

  • Like 1

Share this post


Link to post
Share on other sites

Years ago, while i was in the Ford garage for an oil change, they came up and said my 09 still was running the original Gold coolant. They told me that Ford had discovered that this coolant was found to cause corrosion and clogging. Recommended I switch over to Green coolant.

 

Somewhat expensive, but theres a lot involved. Specific procedures involved in the flush (Gold and Green must never be mixed in the same coolant systems, forms thick sludge and will clog a coolant system).  They also had to change a part in the system as it's is not plated on the inside and the Gold coolant attacks it and causes it to rust.

 

I have a copy of the Ford procedure and will attach it to this reply for your use.

 

If your still running Gold, recommend you do a full proper flush and switch to Green to avoid more problems.

 

2009 MKX Cooling System Corrosion.pdf

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×