Jump to content
Ford Edge Forum
mississippiedge

Check charging system 2012

Recommended Posts

ok, so I've read a few threads but really with no luck, had a check charging system come on intermittently when driving past 40mph, car was charging at 12.5 and down to 11.5 when revved to 2k 

 

replaced the alternator and now car is running rough (I assume ecm needs to relearn since car sat for a while disconnected) anywho after replacing alternator car still has check charging system light stays on 100% of the time

 

Kind of at a loss of words and dont know what to check next. battery is abt 1.5 years old, had a bad battery on it before but never caused poor charging issues.

 

Ideas to check next before I dump 330 dollars on a new battery? (car audio battery) could I have had the luck of buying a bad alternator?

Share this post


Link to post
Share on other sites

Something is definitely drawing and will eventually kill the battery. If you have a OBD reader you can check to see if you have any DTCs that are not portrayed as a check engine light. 

 

Another option would be go to go to autozone/ advanced auto or someplace similar and have them run a check on your charging system.  At least at that rate you have some sort of idea of what your next steps should be.

 

You didn't mention it but is your alternator new or rebuilt? Is it Ford or aftermarket? Some aftermarket parts fail to perform as expected compared to official ford parts.  Not stating this is your problem but its something to consider. 

 

Double check your terminals etc, alarm connections etc just tossing ideas out there. I had what I thought was a good terminal kill a battery on a expedition once. 

 

If your battery is 1.5 years old it should still be under warranty. 

 

Good Luck!

 

Edited by onyxbfly

Share this post


Link to post
Share on other sites

battery doesnt drain when car is off and hooked it up to a scanner and no dtcs detected 

 

going to try and get battery and go from there cuz the alt is new

Share this post


Link to post
Share on other sites

battery doesnt drain when car is off and hooked it up to a scanner and no dtcs detected 

 

going to try and get battery and go from there cuz the alt is new

 

new alt is a Remy alt 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×