Jump to content
Sign in to follow this  
debbyzog

2.0 ecoboost oil pressure issue

Recommended Posts

I recently purchased a 2020 Ford Edge with the 2.0 ecoboost with 50,000 miles. I’ve changed the oil twice and had the same noise each time. The engine rattles for a good two minutes each time with the little oil can pressure light on. Then quiet and normal and no oil pressure light. 
I know that there is some rattling after an oil change for a few seconds due to lack of immediate oil pressure. I always fill the filter with oil before installing. 
First time I used Mobil 1 5w30 and a Mobil 1 filter. The second time I used a Motorcraft filter and Mobil 1 0w30. 
I think the noise comes from the timing chain but, of course I can’t be certain. 
I’m guessing this is not normal but I’ve never had a 2.0 ecoboost before. I’d appreciate and and all input!
After the first oil change we went on a 2000+ mile trip, drove 80+ mph, got 28.5 mpg, and not an abnormal sound out of the engine.

Share this post


Link to post
Share on other sites
34 minutes ago, debbyzog said:

The engine rattles for a good two minutes each time with the little oil can pressure light on. Then quiet and normal and no oil pressure light.

That oil pressure light ON is a bad sign.

 

You've changed the oil twice, that's good, but more important is the service history, and what you're describing could be the evidence of poor maintenance.

 

It may be to late, but the only option is to get an oil pressure gauge on it and confirm where the normal operating pressure is at - a few things could cause low pressure, such as sludge, fouled oil pump suction strainer, bad bearings, .........

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×