Jump to content
Ford Edge Forum
15EdgeSportAWDNewbie

2015 Edge Sport Newbie-Hello!

Recommended Posts

Good Evening and have recently purchased a 2015 Edge Sport. All I can say is wow! My wife travels a lot for work so over the last few years she always commented on how much she liked driving the Edge. We looked at GMC Terrain Denali and Ford Escspe but as soon as I drove the Edge we were sold, then I drive the Sport and I was all in. Anyway just wanted to share my enthusiasm for our purchase and wanted to ask two things here from yall (fellow enthusiasts, experts, and long time Ford owners. I have never been in a forum group so please forgive me if I am not posting properly.

 

My two questions (for now anyway) are:

 

1. Whats are the most important things to keep up on with respect to preventative maint and overall vehicle care.

 

2. How the heck are the front (diver side) parking sensors attached to the bumper facia (bumper cover) my wife went through the car wash and it pushed the sensor through inside the wheel well. I cant seem to see (or find on line) what holds it in place. The closest one looks like it was attached at the factory using an adhesive? Or heat welded in place? I have the whole piece including the painted bracket the sensor mounts in but just dont see what keeps (holds) it in place.

 

Thank you for taking the time to read my post and look forward to hearing how this item stays where it belongs!

 

-Chris B

Tux Blk Sport

Share this post


Link to post
Share on other sites

Welcome to the forums & congrats on your ride. To answer your questions:

  1. Regular maintenance as per the manual in addition to regular PTU oil change (every 15-20K miles) if you have AWD.
  2. See attachment if it helps.

Front Active Park Assist Sensors.pdf

  • Like 1

Share this post


Link to post
Share on other sites

Welcome, and congrats!

  • Like 1

Share this post


Link to post
Share on other sites

Thanks so much for your reply and the drawings. Unfortunaly they dont indicate any type of a bracket the sensor slides in to. It appears that the bracket was heat welded to the bumper cover but that heat weld has failed causing the sensor and trim bracket to fall into the wheel well. I got it out and looked at the others and thats when I noticed what looks like heat welded or some type of adhesive holding the trim bracket in place. Im going to try some silicone adhesive to see if I can get it to stay in place. Thanks again for your help!

Share this post


Link to post
Share on other sites

PTU is the Power Take-off Unit, basically it is gear-set that transfers engine power to the rear. Think of like the Transfer Case for 4WD vehicles except on the Edge it is always connected and has no low range (one ration only). Search the Forums & you'll find many posts on it.

 

PTU fluid replacement

  • Like 1

Share this post


Link to post
Share on other sites

Ok got it. Looks like 2015 and after have built in drain and filler ports. Thanks again for all of your help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×