Jump to content
Fingernip

Poor trans shifting theory investigation

Poor Trans shifting theory  

58 members have voted

  1. 1. Octane used

    • 87 Octane (Regular)
      14
    • 88-90 Octane (Mid grade)
      1
    • 91-94 Octane (High test)
      43


Recommended Posts

On 6/10/2021 at 4:32 PM, Fingernip said:

I don't think you will notice .2 seconds to 60mph in the seat-o-pants meter. Real world says the ST is actually quicker anyway though. 

I noticed it. The one I drove must have been a 2015 because I was still in MA and I test drove it before I bought my 2015 challenger. I am really talking about off the line. The 2015 felt to me like the x5 feels. Instant powe, which is what I expected from the edge ST being an ecoboost. I've got the 265s so I'm not sure I can break the tires loose. I definitely can't just be flooring it. Maybe if I launch with the brakes.

 

I won't tune the car though, probably only have it for another year or so but I don't want to risk any warranty issues (I know, I know, but I'm not going to fight an auto maker in court if they say I voided warranty).

 

I am seriously considering the forscan to turn off auto start stop though. Worst feature on the car. 

Share this post


Link to post
Share on other sites

Running 89 octane in 2020 ST. Major slipping from 2-3 and in/out of 6th. Vibration through the drivetrain,  most notable under light power. Has since new. (15 miles on it then) will post more in another thread.

Share this post


Link to post
Share on other sites

.

Edited by rob19

Share this post


Link to post
Share on other sites
On 6/15/2021 at 10:52 AM, C300 said:

Running 89 octane in 2020 ST. Major slipping from 2-3 and in/out of 6th. Vibration through the drivetrain,  most notable under light power. Has since new. (15 miles on it then) will post more in another thread.

I signed up to these forums for seeing this post. I recently purchased a '19 Edge ST and am experiencing the same exact symptoms. I've read of a possible software update for shifting, but what I've found strange is the vibration/ hopping felt throughout the drivetrain under light power. Was curious if anyone else had dealt with that.

Share this post


Link to post
Share on other sites

I had it. Check if your shocks are leaking.

Share this post


Link to post
Share on other sites
On 6/12/2021 at 8:11 AM, Vanquished said:

I noticed it. The one I drove must have been a 2015 because I was still in MA and I test drove it before I bought my 2015 challenger. I am really talking about off the line. The 2015 felt to me like the x5 feels. Instant powe, which is what I expected from the edge ST being an ecoboost. I've got the 265s so I'm not sure I can break the tires loose. I definitely can't just be flooring it. Maybe if I launch with the brakes.

 

I won't tune the car though, probably only have it for another year or so but I don't want to risk any warranty issues (I know, I know, but I'm not going to fight an auto maker in court if they say I voided warranty).

 

I am seriously considering the forscan to turn off auto start stop though. Worst feature on the car. 

I believe you get more boost in 1st gear on the 2018 and older 2.7 edges. My 2019 with traction control off chirps tires several times on a run to 60 with stock tune but it wont just spin them though. The stock tires don't make a lot of noise though and with windows up and music playing you might not even notice. 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×