Jump to content
blackedgeoak

Malfunction indicator lamp on - brand new 2019 Edge

Recommended Posts

Brand new Edge within 24hrs of deliver in less than 200km, the engine malfunction indicator lamp shows in the instrument panel.

Have checked with the nearest dealer, unfortunately they couldn't identify the root cause, waiting for response from Ford engineers.

Anyone had this issue?

It's really embarrassing to have this in a brand new car.

edge.jpg

Share this post


Link to post
Share on other sites

Hopefully they will get it taken care of in short order.  

Share this post


Link to post
Share on other sites

They are embarrased just as much as you are frustrated! They will escalate it and a Ford engineer will sort you out!

Share this post


Link to post
Share on other sites

I once test drove a 2020 and pulled over and noticed they hadn’t hooked up the batter correctly.

 

when I bought mine the next day the light went on and battery died soon after. 
 

just curious what was the final solution?

Share this post


Link to post
Share on other sites

I took the car to dealer and also contacted Ford directly, after diagnosis they came with below finding and fixed by replacing the part. It's been 10 months now and I love my edge.

*****we have scanned your check engine light, we have ordered a brake vacuum tube assembly. This causing an uncommanded high air flow intake manifold leak******

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×