Jump to content
IcyFridge

Downgrade 4" Sync to 3.3?

Recommended Posts

I updated to Sync 3.4 on my 4.2" Sync with My Ford. It seems to be a little buggy. Whenever I start the car, it defaults to the radio screen (but the radio is not on), when engine is powered off and before the door is opened it will switch between day and night mode randomly, when turning off the radio it will flash the screen with the previous one several times before settling in the clock screen. 

 

Wonder if anyone has the old update file for 3.3 that I can try to downgrade to? Remember, this is not for the 8" Sync 3. 

I've done the reset, etc etc and was wondering if someone had the file so I can try downgrading before having to take off work to go to the dealership. 

Share this post


Link to post
Share on other sites

Update : Even though the update for my Sync was an official one from Ford, the dealer said that I need a new APIM. I've heard of this happening over the years. You'd think that Ford would be able to fix this without having to replace the APIM.

 

I sure miss my Edge, and will be without it for a few days. At least I get to play with the Sync3 3.4 in the 2020 Escape loaner I have. I'm surprised at how peppy that 1.5L Inline 3 is.

Share this post


Link to post
Share on other sites

Update 2: picked up my Edge and all was well until I got home. Sync is doing the exact same thing, even with a new APIM. 

 

I'm about ready to just get a new head unit but don't want to lose my Sync functions. 

Share this post


Link to post
Share on other sites

CyanLabs can help you downgrade if that's what you want.  Depending on the version of upgrade you received you could theoretically upgrade beyond the version that you were provided, which may also provide you with a solution as several things were fixed in the most recent available version (3.4.20196 is the newest one, 3.4.20136 is the one being sent out by Ford last I checked.)

Share this post


Link to post
Share on other sites
3 hours ago, Firestar said:

CyanLabs can help you downgrade if that's what you want.  

The thing is that they work specifically with the 8" Sync3. I'm using the 4" Sync with MyFord (non touch). I did send them a message to see if they can provide the download link for the 3.3 (4"). 

 

It's dumb that both the 8" and 4" Sync get the exact same file version named Sync3 Version 3.4.20136. I tried using Cyan's version and that produced interesting results. See it here: http://imgur.com/a/5euph9Y

Edited by IcyFridge

Share this post


Link to post
Share on other sites
16 hours ago, IcyFridge said:

The thing is that they work specifically with the 8" Sync3. I'm using the 4" Sync with MyFord (non touch). I did send them a message to see if they can provide the download link for the 3.3 (4"). 

 

It's dumb that both the 8" and 4" Sync get the exact same file version named Sync3 Version 3.4.20136. I tried using Cyan's version and that produced interesting results. See it here: http://imgur.com/a/5euph9Y

 

I don't think its dumb.  Ford provides the authorized files specific for your vehicle from their own website by VIN.  Pulling files from any other site is not authorized by Ford for use in your vehicle and using them is entirely at your own risk and if you render your system useless Ford would have no obligation to correct it warranty.  The file names thenselves are different between the 4" and 8".   A software version and build date doesn't determine the file name.  With some research you can determine what files were likely in your vehicle for version 3.3, then find them and install them.

 

Unauthorized changes can cause issues for dealers and potential future owners.  I just dealt with a person that needed a replacement APIM for their 17 F150 that was purchased used.  While the APIM was bad (failed BT, lagging nav etc.), programming the replacement resulted in an odd display and it would not function properly.  Ends up the previous owner enabled the GT display which isn't supported in version 3.0 19205.  The programming data had been "updated" on the Ford build server and was pulling non-supported settings into the APIM via the official programming process. Ford is aware people are doing stuff like this and will not cover these issues under warranty.  I was able to correct this but most dealers wouldn't have the knowledge to do this and have to contact Ford who then has to have someone manually go into the vehicle build file and correct the modified programming.

Share this post


Link to post
Share on other sites

Yeah. I only tried the Cyanlab version because the official update from Ford "broke" my Sync. Even after a new APIM, it still does the same thing.

 

And I've tried to look everywhere online for the 3.3 file, but can't seem to locate it at all as it was included OEM for the 2019 Edge. I can find files for the older version of the 4" sync, but I don't want to risk running that on mine. I have a feeling the hardware is different, which is why there are different file versions (EG: Older 4.6 vs Newer 3.4.20136). The only place I know that has 3.3 is Cyanlabs, but as you saw in my picture, that doesn't work as it's made for the 8" screen. As of right now, I'm just gonna have to deal with it and wait until an opportune time to have the dealer run their "diagnostics" on it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×