Jump to content
skiutah1080

HELP! 2017 Ford Edge SEL - Dual Climate Control HEAT not working!

Recommended Posts

Need some help...  

I have a 2017 Ford Edge SEL 2.0 with dual climate control.  No matter what temp I set the climate control at I am getting NO heat at all.  

Rather than pay a $110 diagnostic fee I'd rather reach out to see if there are any "simple" solutions first.  

This just started happening the last couple days.

  • Like 1

Share this post


Link to post
Share on other sites

Hi my heat just went out on same vehicle. Did you get a solution?  Thanks 

Edited by oscsbkj

Share this post


Link to post
Share on other sites

Check your coolant tank and see if it's low.  (Back left of engine bay)

Open your oil cap and see if it's miscolored, pull your dip stick and see if it's miscolored.  

 

If your oil looks pasty or "not like oil should look" you likely have a coolant leak into the cylinder as well.

 

The ONLY thing that multiple mechanics told me was a solution was a full engine replacement.  

 

Hopefully you're under warranty.

Share this post


Link to post
Share on other sites

On the same note, if everything (coolant, oil, etc) looks ok it's likely something else... 

Share this post


Link to post
Share on other sites

Hook up a OBD code reader and see if you are getting any DTC/ error codes.

Share this post


Link to post
Share on other sites
On 12/10/2019 at 12:04 PM, skiutah1080 said:

Need some help...  

I have a 2017 Ford Edge SEL 2.0 with dual climate control.  No matter what temp I set the climate control at I am getting NO heat at all.  

Rather than pay a $110 diagnostic fee I'd rather reach out to see if there are any "simple" solutions first.  

This just started happening the last couple days.

 

Okay lets start with the basics:

  1. is the car getting up to temperature
  2. is the blower motor functional
  3. does the a/c work
  4. if you lock the dual climate and go to two extremes does it work
  5. if you put the zone at the most extreme opposites do they work

 

14 hours ago, oscsbkj said:

Hi my heat just went out on same vehicle. Did you get a solution?  Thanks 

 

maybe we can internet trouble shoot this

 

14 hours ago, skiutah1080 said:

Check your coolant tank and see if it's low.  (Back left of engine bay)

Open your oil cap and see if it's miscolored, pull your dip stick and see if it's miscolored.  

 

If your oil looks pasty or "not like oil should look" you likely have a coolant leak into the cylinder as well.

 

The ONLY thing that multiple mechanics told me was a solution was a full engine replacement.  

 

Hopefully you're under warranty.

 

if they are trying to get you to replace an engine for no heat, get a new shop.

 

if you have milk in your oil pan, and you caught it with few miles on it, you dont necessarily need a new motor, many things can lead to this.

 

9 hours ago, onyxbfly said:

Hook up a OBD code reader and see if you are getting any DTC/ error codes.

 

this needs to be done too, look for secondary codes also.

  • Like 1

Share this post


Link to post
Share on other sites

Hey all. New here. Owner of a Ford Edge for 2 months and this morning I had the heat issue. Ac works great. But no matter the temp heat does not come out. Did anyone find a fix for this or at least what the problem was? I have not tried the different extreme temps yet. Any help would be great. 

Share this post


Link to post
Share on other sites
1 hour ago, Lj40 said:

Hey all. New here. Owner of a Ford Edge for 2 months and this morning I had the heat issue. Ac works great. But no matter the temp heat does not come out. Did anyone find a fix for this or at least what the problem was? I have not tried the different extreme temps yet. Any help would be great. 

 

Have you checked your coolant tank?  

Share this post


Link to post
Share on other sites

I have had the same problem with my 2013 EDGE.  My mechanic checked the actuator codes and got B11E-5 AND B11E-6.  He cleared the codes and the heat worked fine.  First time he charged $50 second he charged $40.  He told me that I need to go to Ford and have them reprogram my climate control module.

Share this post


Link to post
Share on other sites
On 9/23/2020 at 5:32 PM, Lj40 said:

Hey all. New here. Owner of a Ford Edge for 2 months and this morning I had the heat issue. Ac works great. But no matter the temp heat does not come out. Did anyone find a fix for this or at least what the problem was? I have not tried the different extreme temps yet. Any help would be great. 

@Lj40 what year is your Edge?  if 2011-2014, you have 3 electronic/programming options: try recalibrating the unit yourself, have the dealer reprogram it, or replace the blend door actuators.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×