Jump to content

Recommended Posts

🙁 Had our 2020 Edge ST  about 4 months and really like it. Delivers on most all it promises. Recently had parked it in the garage for the night in the usual way. The next morning all the electrical components were dead. Voltage across the battery terminals was 4.2 Volts. Jumped the battery from my other vehicle and got it started. The only message was a “power train malfunction please see the dealer.” Drove it to the local dealer (about 20 minutes) and they could find nothing wrong and cleared the power train warning. They also said the battery tested at 12.6 volts even though no additional charging was done. They also recommended that I should have it towed in if it happens again.

Anyone have any thought as to what happened.

 

Share this post


Link to post
Share on other sites

Battery getting weak (can't really tell just using a voltage test, you MUST run a  load test or test the CCA rating to get an actual measure on the battery. A weak battery can test good voltage wise, but goes down quickly as it gets under load). 

 

Other possibility is a power draw. Light left on, hatch left open, that type of thing. Was ANYTHING plugged in?

 

 

Edited by enigma-2

Share this post


Link to post
Share on other sites

charge the battery with a smart charger.  driving will not bring it back to life, it is too far gone for that.  you can put it on a pulse charger for some time, but you have to monitor it periodically for voltage and temperature.

 

or as YT videos show, if it is an AGM battery, put it in series with a known good SLA battery and get the voltage up to above 11V.  Then you can charge the AGM battery directly.

 

Or get a new battery and keep it charged.  If not driven much, or not far at highway speeds, it probably needs to be on a tender on a regular basis.

Share this post


Link to post
Share on other sites
Guest Corey

Had the same exact issue on ours this morning. Did you ever find out what the cause was and how it was fixed?

Share this post


Link to post
Share on other sites
20 minutes ago, Guest Corey said:

Had the same exact issue on ours this morning. Did you ever find out what the cause was and how it was fixed?

Have you tried some of the suggestions and recommendations in this thread?

Share this post


Link to post
Share on other sites
Guest Corey

No not yet as i am at work and the car is at home with unhappy spouse.

Share this post


Link to post
Share on other sites
Guest Corey
On 3/5/2021 at 4:03 PM, ALDriver said:

🙁 Had our 2020 Edge ST  about 4 months and really like it. Delivers on most all it promises. Recently had parked it in the garage for the night in the usual way. The next morning all the electrical components were dead. Voltage across the battery terminals was 4.2 Volts. Jumped the battery from my other vehicle and got it started. The only message was a “power train malfunction please see the dealer.” Drove it to the local dealer (about 20 minutes) and they could find nothing wrong and cleared the power train warning. They also said the battery tested at 12.6 volts even though no additional charging was done. They also recommended that I should have it towed in if it happens again.

Anyone have any thought as to what happened.

 

 

Any updates?

Share this post


Link to post
Share on other sites

12.6 volts is really meaningless in today's cars. Couple of years ago we were out shopping. Short trips to various stores. Was at local grocery, and when we came out the battery wasn't able to turn the car over. I carry an emergency  jumper battery and was able to jump the car and get it started. But it was an old battery that finally wasn't able to take a sufficient charge with so many short trips. 

 

In today's cars, you need to test the battery by testing the CCAs (dealers refer to this a test under load). Even a weak battery can test good volts at rest, and certainly should have charged up during the drive to the dealer. 

 

Start by doing a CCA test of the battery. (Eleminate the obvious).

Edited by enigma-2

Share this post


Link to post
Share on other sites

Check the date code on the battery. I have heard a lot of stories about Service Techs swapping their old broken batteries from their vehicles into dealer vehicles or vehicles that come in for service/warranty work.  Pretty messed up, but from what I hear, it happens a lot.  If the battery is older than the vehicle, you should talk to the dealer about it.

  • Confused 1
  • Sad 1

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×