Jump to content
alzakx

2015 Edge - First Year Model Problems?

Recommended Posts

Al:

Stop stressing. Is this the vehicle you want and can afford.? If so, go buy it!

I'm 62 years old and this is my second Ford since my 1976 Ford van. Stop the angst about "1st" year models. This is just a revision of the past year models, not a totally brand new design. If we didn't have the Internet you wouldn't even know about the "rattle". And that issue has been resolved. The other issues happen with ALL vehicles: parts fail. DESIGNS ARE NEVER PERFECT.

I've owned a dozen new vehicles in my life, and I can say the new Sport is as good as anything I've owned (Lexus, Mini, Vettes,Nissans, and more).

It's a machine!! It's never going to be perfect....

Sorry, just how we roll in the US of A!

  • Like 1

Share this post


Link to post
Share on other sites

Didn't realize this was a 2015. Take it to the dealer and let them worry about it. They can reload the software and replace the APIM if necessary.

Share this post


Link to post
Share on other sites

Al:

Stop stressing. Is this the vehicle you want and can afford.? If so, go buy it!

I'm 62 years old and this is my second Ford since my 1976 Ford van. Stop the angst about "1st" year models. This is just a revision of the past year models, not a totally brand new design. If we didn't have the Internet you wouldn't even know about the "rattle". And that issue has been resolved. The other issues happen with ALL vehicles: parts fail. DESIGNS ARE NEVER PERFECT.

I've owned a dozen new vehicles in my life, and I can say the new Sport is as good as anything I've owned (Lexus, Mini, Vettes,Nissans, and more).

It's a machine!! It's never going to be perfect....

Sorry, just how we roll in the US of A!

AMEN!

Share this post


Link to post
Share on other sites

Yeah, I'm waiting for the 2016 to come out. My dealership would get it probably early next year.

 

As long as the 2016 don't have the transmission problems seen on youtube

 

https://www.youtube.com/results?search_query=ford+edge+transmission+problem&page=&utm_source=opensearch

 

I guess it's ok.

Share this post


Link to post
Share on other sites

I'm curious why the body seal leaking issue isn't getting any attention. The thread is in "The Lounge" which seems like a strange place to put it.

 

http://www.fordedgeforum.com/topic/17965-driver-floor-is-soaking-wet/

 

 

oh wow, that's about the most annoying problem to have in a brand new car. Nothing ruins your driving experience like a musty interior. I can't believe that such a huge seal issue would pass inspection. It sounds like people's floor mats are soaked, that can't be from a pinhole sized leak.

Share this post


Link to post
Share on other sites

oh wow, that's about the most annoying problem to have in a brand new car. Nothing ruins your driving experience like a musty interior. I can't believe that such a huge seal issue would pass inspection. It sounds like people's floor mats are soaked, that can't be from a pinhole sized leak.

Exactly. I am going to check my floors after work. It just rained hard here and my Edge is outside. It has rained a few times, pretty hard, since I bought the Edge and haven't noticed any water or musty smell. But I'd really like to see where this seal is and if I can access it to verify it is in fact sealed.

Share this post


Link to post
Share on other sites

Al:

Stop the angst about "1st" year models. This is just a revision of the past year models, not a totally brand new design.

Actually, the 2015 Edge is a totally brand new design. It has a completely new platform that is not related to the older generation, only the 3.5L V6 is carried over.

Share this post


Link to post
Share on other sites

just wanted to give a heads up to the new edge owners out there!

with less than 175 miles on my wife's new sport the check engine light came on.

tried running a vehicle health report only to find out the vehicle needs a minimum of 200 miles on it before this service functions. returned to the vehicle to the dealer and they ran some tests which indicated a faulty sensor.

was told it was the waste gate vacuum sensor. the dealer had to order it from ford and have it shipped in. was not very happy to have the vehicle in our driveway for two days then back at the dealer for three days! everything seems fine now. overall I think the wifey loves the edge.

post-34941-0-56564800-1433687026_thumb.jpg

Share this post


Link to post
Share on other sites

How many are having problems with water coming on the drivers side floor due to a faulty or no seal. Can you get Ford to replace the carpet. Canadian dealer has not heard of problem.

 

CCA

Share this post


Link to post
Share on other sites

How many are having problems with water coming on the drivers side floor due to a faulty or no seal. Can you get Ford to replace the carpet. Canadian dealer has not heard of problem.

 

CCA

 

Here you go:

 

http://www.fordedgeforum.com/topic/17965-driver-floor-is-soaking-wet/

Share this post


Link to post
Share on other sites

I purchased the 2015 Titanium, the HID light on the passenger side went out driving it home from the dealership. Took it back the next day, and it has been in the shop since (three weeks). They still can't figure out what is wrong.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×