Jump to content
Sign in to follow this  
Aldjmc

2016 Panoramic Moonroof won't close

Recommended Posts

No argument that these problems are happening too frequently. It's definitely a problem. But don't blame Ford because you bought a used car you didn't inspect with a warranty you didn't read.

Share this post


Link to post
Share on other sites

had the same problem -moonroof opening ok, but closinng verysluggish until stoped at 8 inch before full close. tried initialization/reinitialization, etc. do not do this - you will worn out cables and teeth on the moving mechanism. the issue was missing lubrication on the rear half of the sliders. they are covered by two rubber tubes(like). puling them a bit aside i saw straight down white, dry track on which sliders are runing back and force. used White Lithium Grease can with a thin (0.5mm) red tube usually attachetd to the can. just pushed tube between two rubber tubes(like) covering slider track and i pressed the lithium greace cap and sprayed grease all the way moving it along the track. i believe mine was not lubricated properly at the factory(2016 edge with vin starting with 2:(!!!). on older's i believe the lubrication in that place can be washed by high water pressure driving in the rain on high speed or ussing soappy power wash.

that's it. now my edge's moonroof moves even faster than when it was new(a year ago). feel free to ask questions.

btw i found very usefull youtube videos on edge panoramic roof maintenance

Edited by almun

Share this post


Link to post
Share on other sites

Believe that the unit is designed to work without any lubrication (the service manual allows silicone spray if needed). Be aware that lithium grease will eventually gum up when exposed to water and cold, and cause sticking problems by itself. MacFordEdge did a really good video on how to remove the glass, clean and lubricate the rails to prevent future problems.

Share this post


Link to post
Share on other sites

My 2 week old Edge roof is closing but I have noticed there is a slight gap between the glass and the seal. I'll be away for 2 weeks starting tonight and my car is going to sit in a parking lot and I'm worried about rain getting into the car while I am gone. Anyone else notice this? I'll try to post a picture.

Edited by Mirage52

Share this post


Link to post
Share on other sites

Maybe tape it up with painters/gaffers tape before you leave it in the lot? Should hold up.

 

Of course, ensuring that the rails are clean, the drains are unclogged, and the seals are not warped/are sitting properly are also on the table here.

Edited by WWWPerfA_ZN0W

Share this post


Link to post
Share on other sites

You know what is somewhat maddening to me is the fact that the BAMR is a forced option for those who want the better equipment that come with the 301 and 302 packages for the Titanium model. I have always felt that my BAMR was a problem waiting to happen. Ford needs to make this a stand alone option as in the Sport Model or give us the option of deleting it from the packages. This feature has been on the Edge since its inception, you think they would have gotten it right by now! Too bad.

  • Like 1

Share this post


Link to post
Share on other sites

I understand not wanting it in the first place, but if you're forced to get it and you're worried about it failing just don't open it. Even without opening it's worth it just to get the view IMO.

Share this post


Link to post
Share on other sites

Like many others, my wife's 2011 Edge sunroof wouldn't close all the way. I followed the excellent MacFordEdge video to remove the glass panel and the first thing I saw was that the cable guide on the left side was cracked in half. (Not sure if that's what its called, but the plastic looking piece that pulls the glass open and shut). Confirmed that once the guide moves forward the front bracket that would hold the glass pops out of the guide at that point.

 

Does anyone know the part number for that guide and whether those guides can be replaced on their own or if the whole cable system needs to be replaced? Any help or guidance would be greatly appreciated.

Edited by Philip Banik

Share this post


Link to post
Share on other sites
On 9/25/2017 at 8:46 PM, Philip Banik said:

Like many others, my wife's 2011 Edge sunroof wouldn't close all the way. I followed the excellent MacFordEdge video to remove the glass panel and the first thing I saw was that the cable guide on the left side was cracked in half. (Not sure if that's what its called, but the plastic looking piece that pulls the glass open and shut). Confirmed that once the guide moves forward the front bracket that would hold the glass pops out of the guide at that point.

 

Does anyone know the part number for that guide and whether those guides can be replaced on their own or if the whole cable system needs to be replaced? Any help or guidance would be greatly appreciated.

Unfortunately it only comes with the rail.

https://www.tascaparts.com/oem-parts/ford-lift-channel-7t4z78502c07b/?c=Zz1ib2R5JnM9c3Vucm9vZiZpPUtHMTA1NDU1JnI9MTEmYT1mb3JkJm89ZWRnZSZ5PTIwMTEmdD1saW1pdGVkJmU9My01bC12Ni1nYXM%3D

 

https://www.tascaparts.com/oem-parts/ford-lift-channel-7t4z78502c06b/?c=Zz1ib2R5JnM9c3Vucm9vZiZpPUtHMTA1NDU1JnI9MTEmYT1mb3JkJm89ZWRnZSZ5PTIwMTEmdD1saW1pdGVkJmU9My01bC12Ni1nYXM%3D

 

Edit: 

An after market solution is now available: http://www.sunroofdoctor.com/2007-2014-Ford-EdgeLincoln-MKX-Sunroof-Guide-Repair-Kit-_p_112.html

Edited by omar302
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Anyone confirm that the part that Left and Right guides ride in (carrier?) comes with the Lift Channel? The part that actually pushes and pull the the roof, and pushes down the deflector net as it closes.

 

Lubed mine up pretty well but those metal rails do not like the Arizona heat.

 

Just trying to find a good picture or some confirmation before I order.

Edited by WPNZ

Share this post


Link to post
Share on other sites

My 2012 Edge panoramic moon/sun roof made a pop sound today while I was closing it. Then it would not move forward to close. I would push the button to close it and it would "inch" forward a tiny bit, but then opened back up on its own. It opened fine. We forced it closed while pushing the button.. later, I closed the blind and it closed fine. I'm afraid to try the initializing procedure in case it opens again and won't close. Guess I will have to take it to my mechanic. I love my Edge, bought it used, but don't want to put a bunch of money ($4k mentioned before) to fix that issue. 

Edited by Pspiller

Share this post


Link to post
Share on other sites
9 minutes ago, Pspiller said:

My 2012 Edge panoramic moon/sun roof made a pop sound today while I was closing it. Then it would not move forward to close. I would push the button to close it and it would "inch" forward a tiny bit, but then opened back up on its own. It opened fine. We forced it closed while pushing the button.. later, I closed the blind and it closed fine. I'm afraid to try the initializing procedure in case it opens again and won't close. Guess I will have to take it to my mechanic. I love my Edge, bought it used, but don't want to put a bunch of money ($4k mentioned before) to fix that issue. 

 

Unfortunately, if you heard a pop it probably means one of the front clips broke. If it did break, the initializing procedure will not help. the good news is that there is now an after market solution that costs way less. I haven't tried it, nor do I remember if anyone in this Forum posted about using them. They weren't available before I sold my 2011 MKX.

 

http://www.sunroofdoctor.com/2007-2014-Ford-EdgeLincoln-MKX-Sunroof-Guide-Repair-Kit-_p_112.html

  • Like 1

Share this post


Link to post
Share on other sites

After hearing how my brother say how he really loved his Edge I bought one.... 2016 Titanium. Day 2 the Moonroof opened perfectly, started to rain tried closing the roof and motor struggled and wouldn’t close. Next morning it closed and opened perfectly. Thought it was just a fluke.Drove around for about an hour and decided to open and then started sprinkling again and tried closing the roof WTHECK it didn’t close. It seems to happen after driving around for about an hour. Anyway this happened 2 more times and then some service lights came on. Is this an electrical problem that is effecting everything in the car?  It is sitting at the dealership right now I’m really worried since I just purchased this car and have no other vehicle to get around in. I hope this is something they can fix it won’t cost a lot. Very disappointed in Ford

Share this post


Link to post
Share on other sites

I just bought a 2016 Edge Titanium- very low milage ( 5 days ago). Within two days having a problem with sun roof and “ steering assist fault service repair light has come on.... I’m getting really nervous now if this year of edge is a lemon year or if I just hit a couple snags and this is a reliable car. My brother had a 2014 and it was a great car. I researched and checked this car out head to toe but now am second guessing owning this car and a Ford. Please... any suggestions advice to calm this old lady’s worries TIA

Edited by Sheriew17
Left out tag

Share this post


Link to post
Share on other sites
3 hours ago, Sheriew17 said:

After hearing how my brother say how he really loved his Edge I bought one.... 2016 Titanium. Day 2 the Moonroof opened perfectly, started to rain tried closing the roof and motor struggled and wouldn’t close. Next morning it closed and opened perfectly. Thought it was just a fluke.Drove around for about an hour and decided to open and then started sprinkling again and tried closing the roof WTHECK it didn’t close. It seems to happen after driving around for about an hour. Anyway this happened 2 more times and then some service lights came on. Is this an electrical problem that is effecting everything in the car?  It is sitting at the dealership right now I’m really worried since I just purchased this car and have no other vehicle to get around in. I hope this is something they can fix it won’t cost a lot. Very disappointed in Ford

You bought a used car, possibly not well maintained.

 

There is some maintenance required for the moonroof - have you checked to see if that's been done.

 

 

  • Like 1

Share this post


Link to post
Share on other sites

The car only had 20,000 miles on it. I had a mechanic check over it and the CARFAX maintenance info and he said it was clean and looked like it had been maintained at the correct intervals. The dealership is servicing it right now and will let me know what the problems are as the “Steering Assist” failure service required light also came on. 🤞🤷‍♀️🤞🤷‍♀️🤷‍♀️🤞🤞

Share this post


Link to post
Share on other sites
1 hour ago, Sheriew17 said:

The car only had 20,000 miles on it. I had a mechanic check over it and the CARFAX maintenance info and he said it was clean and looked like it had been maintained at the correct intervals. The dealership is servicing it right now and will let me know what the problems are as the “Steering Assist” failure service required light also came on. 🤞🤷‍♀️🤞🤷‍♀️🤷‍♀️🤞🤞

CarFax is not a reliable source for maintenance records, and the only way an independent mechanic can confirm the service history is viewing a paper copy of each service, or if was serviced by Kia then they'll have the record, but you don't need to be a mechanic to review a written service record.

 

The servicing of the moonroof isn't always logged.

 

I bought my Edge new, but other used vehicles I've bought, a verifiable service record needs to be produced before money changes hands.

 

Who was the previous owner and who did you buy it from?

 

 

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, Sheriew17 said:

The car only had 20,000 miles on it. I had a mechanic check over it and the CARFAX maintenance info and he said it was clean and looked like it had been maintained at the correct intervals. The dealership is servicing it right now and will let me know what the problems are as the “Steering Assist” failure service required light also came on. 🤞🤷‍♀️🤞🤷‍♀️🤷‍♀️🤞🤞

 

Did your mechanic check for codes? Some codes can be disabled and leave a permanent trace I.E. frozen code. IIRC there was a recall on the 15-16MY for adaptive steering.  I don't recall when the expiration date was. I'm pretty sure it expired though. 

 

Not to scare you but trying to inform you.  There are a few different steering related recalls for your year. There is the adaptive steering one which I mentioned where they will replace the steering wheel, there is another where they replace the steering wheel bolt and another where they have to replace bolts in the steering gear box,  There may be one, but I can't remember it off the top of my head.

 

Good luck maybe the dealer can reach out to Ford on your behalf because the country was shut down and the vehicle wouldn't have been serviced for the recall if it was sitting on a dealers lot... That would be an angle, I would definitely peruse. 

Share this post


Link to post
Share on other sites

Thank you for all the info. No he didn’t have time to check the codes. One recall that is still open is getting fixed next week. I will have dealership look into the others. When I checked for recalls it only showed that one. I didn’t know a recall could expire. Again thank you for all of the information. 

Share this post


Link to post
Share on other sites

I have the 2016 Edge SEL bought new. It has been very reliable.

 

The only repair done was the APIM, which is the computer controlling SYNC. Otherwise, it's been a great car.

 

Take it back where you bought it, 5 days is too short a time to start having problems on an expensive car like this.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×