Jump to content

Recommended Posts

@1004ronThis problem isn't limited to 2015 and up. My 2011 had the same fluttering air shields because the pins were loose and rattling in their holes. On inspection, the fender well pins exhibited the same behavior. So when an Amazon package arrived for me with hi-density-poly foam panels, I sliced off 1/4" pieces and made 1"x1" square washers. I popped each of the plastic rivets with one of the body tools that removes them, put the newly minted washers on them and popped them back in.  Luckily it was black foam. No more noises! It took me only 2 years to find where the noise was coming from-LOL.

 

It's apparent that the new fastening system will not lend itself to my fix, but you might think about winding hi-density foam strips around the string (like a twist tie) before winding the string around the new fastener. It will probably last longer. The foam is pretty robust and stiff. Mine's been fine for nearly 2 years now.

 

Good luck!

  • Like 1

Share this post


Link to post
Share on other sites

@bb56  I can envisage those washers working, and I have some of that foam you described and will give that I try.

Share this post


Link to post
Share on other sites

I gave another method a shot after mine started vibrating again. I waited a few weeks before posting so I could test that they have been working for me. Basically I used strips of duct tape to fashion my own washer between the gap. Once I got a good amount of tension I placed a zip tie around the duct tape to keep it secure. It might not be the prettiest or the most proper job, I'm sure foam is a better bet. For me though, this worked great. I figured I would post it for anyone just wanting to try a free fix, I am sure just about everyone has these supplies on hand. 

IMG_0701.jpeg

  • Like 1

Share this post


Link to post
Share on other sites

Besides being a poor design, even after you replace them the problem will come back after an oil change.

After my first oil change this rattle started, went back to the dealer and asked if all the grommets were put back. I was told one was broke and they fixed it, drove the car home same noise... I hate rattles. I bought the 6 pack and replaced the worst one - hard to do on the floor in the garage.  Time for a test drive ;)

Share this post


Link to post
Share on other sites

Has nothing to do with an oil change?  Those long underbody panels are not touched.

Share this post


Link to post
Share on other sites

Hi All,

 

I know I am responding to a quite old thread. But I had a few questions.

 

So as per the post, I applied some similar fixes. But after some talks and especially Reddit, some people suggested to simply just take it off which I am not quite in favor of.

 

The other is people simply removed the clips just resting the guard on the 10mm nuts, which I think might work but then I am concerned if that will have adverse, especially when driving at highway speeds.

 

Can anyone give their opinions?

 

Thanks!

Share this post


Link to post
Share on other sites

I wouldn't take the covers off - it offers protection to things like the brake and fuel lines.

 

I applied the foam washers and new fasteners as per the Tech Bulletin and as I commented in this thread it didn't silence it for long.

 

I recently used zip ties and the buckle of the ties keeps the plastic posts cocked to one side and I believe that's going to keep quiet for longer.

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Hi All,

 

Firstly, I am new to these forums so apologize if I made any mistakes posting this.

 

So, talking about the concern I have is. I have a highway rattle that occurs due to splash guard or underbody shields that are on both sides of the driver and passenger. I did fix it temporarily applying the idea from the post as mentioned.

https://www.fordedgeforum.com/topic/24176-solved-noise-or-rattle-above-40mph/

 

However, I am looking for a permanent fix. After some talks and Reddit, people suggested taking those splash guards off but I am not sure if I should do it since it kinda protects the metal frame.

 

But few suggest to take the clips off and leave if rested there by 10mm nuts which I think can work but can anyone suggest if it would be a good idea and if it will not harm anyway in the later run or saying driving at highway speeds.

 

Thanks!

Edited by 1004ron
Keep it to one thread - same topic

Share this post


Link to post
Share on other sites

Is it just me or is the under carriage  cover a pain and noisy? What is the purpose of it and has anyone removed it because they are tierd of hearing it rattle 

  • Like 1

Share this post


Link to post
Share on other sites

My guess is they're there to create a more streamlined airflow to improve aerodynamics. Others in a BMW forum argue it protects the engine bay from road debris. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×