Jump to content
WWWPerfA_ZN0W

What have you done to/with your Edge/MKX today?

Recommended Posts

1 hour ago, Nick Halstead said:

all my forscan mods have been while tuned. Are you on licensed version of Forscan

Yes, I got the 2 month free license.  

Share this post


Link to post
Share on other sites
3 hours ago, Jombi said:

Does one need to revert custom tunes to stock before doing these Forscan changes?  I don't know if I have the wrong version of Forscan or not (I've tried the three latest betas) but I get an error to the effect of "Can't change config". 

 

However, on a hunch, I reverted my LMS tune back to stock, and attempted the exact same changes, and Forscan changed them fine.  The changes did indeed work, even after re-applying the tune.  So I'm just wondering if this is a known thing--that you revert to stock before messing with Forscan, or if I am doing something wrong.

 

 

I also have the LMS tune and ForScan works fine, with the LMS & with stock. No difference. Using regular build of ForScan, no special version required.

 

However, I noticed that @Nick Halstead & I both have Sports, you have an ST. So maybe LMS's tune is setup differently on the ST. Note that with some Tuners/Ford models, ForScan connection would not work automatically, a message similar to "unable to connect to vehicle ------ if PCM has a custom tune installed please enter the strategy/calibration name or part number of factory PCM" would appear. I guess you did not get such a message since you were able to read data, only the write process did not work. If you want to try something, when connecting ForScan while Tuned, don't load the saved Profile, let ForScan re-read all modules again while the Tune is applied and see if it then works.

  • Like 1

Share this post


Link to post
Share on other sites
8 hours ago, omar302 said:

 

I also have the LMS tune and ForScan works fine, with the LMS & with stock. No difference. Using regular build of ForScan, no special version required.

 

However, I noticed that @Nick Halstead & I both have Sports, you have an ST. So maybe LMS's tune is setup differently on the ST. Note that with some Tuners/Ford models, ForScan connection would not work automatically, a message similar to "unable to connect to vehicle ------ if PCM has a custom tune installed please enter the strategy/calibration name or part number of factory PCM" would appear. I guess you did not get such a message since you were able to read data, only the write process did not work. If you want to try something, when connecting ForScan while Tuned, don't load the saved Profile, let ForScan re-read all modules again while the Tune is applied and see if it then works.

I tried last night and got it to work rip or some items with the tune installed, and I think it was a combination of a couple of things.  First I let it load the live profile instead of re-loading my last saved profile (I save the profile each time with comments on what I change), so that I think helped, thank you for that.
 

Second, on some of the modules, I’d get a “battery voltage low” warning, when going into the programming mode for that module—not all modules though.  It was in those modules I’d get the error when writing a change, which was “service procedure interrupted”.  I think that when I’d reinstated the stock tune, I’d drive the car a bit, which charged the battery, then when I went to programming mode subsequently, I would not get the battery low warning and those module changes then succeeded.  
 

I had a charger and hooked it up when I first got the low battery warning but somehow even after 20 min charging, and testing voltage with a multimeter, FORScan always seemed to display the low voltage warning for those select modules even though I know there was plenty of charge.  This may be a bug in FORScan.

Share this post


Link to post
Share on other sites

Saw the post about using car vinyl instead of Plasti-dip to color the grill trim pieces. Wanted to try it on something small first, so I did the interior trim piece to match the exterior blue paint.  
539843814_interiortrim.thumb.jpg.d2fdd6b4dc1023f2bc42ad32f5739c4b.jpg
 

  • Like 2

Share this post


Link to post
Share on other sites

Looks good! I'm prepping to do a chrome delete, inside and out. Mostly matte black vinyl, but gonna throw some of that blue in strategic places as well. Mines the same color, is that vvivid vinyl? What color is that? It looks like it matches lighting blue metallic pretty well. 

Share this post


Link to post
Share on other sites

So far I have installed weathertech inchannel rain guards ,and black grill insert on my stone grey 2019 SEL looking to change wheels have factory 5 spoke alloy wheels now,I would like to use my new michilns that came with car,any suggestions?

image.jpg

image.jpg

Edited by Engr146
Finally was able to add pic!
  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, soUNTOUCHABLE said:

Looks good! I'm prepping to do a chrome delete, inside and out. Mostly matte black vinyl, but gonna throw some of that blue in strategic places as well. Mines the same color, is that vvivid vinyl? What color is that? It looks like it matches lighting blue metallic pretty well. 

I think that's pretty cool, there's too much chrome on this car for my taste.  The color is Deep Blue Metallic and I got mine off of Amazon, but Vivid Vinyl does sell it too. I think the part number for it is 1080 G217? It is super close to the factory color, but off by just enough that you couldn't use it for exterior trim. I was hoping to use the blue on the front grill but it was obvious that the colors didn't match. 

Share this post


Link to post
Share on other sites

 Gotchya, I think 1080 is 3m. Vvivid has a blue that looks close, but I havent ordered it yet to try it out. Of course their sample books are always sold out. 

Anyways, nicely done!

 

Btw,if you're looking for head/tail light tint. Vvivid is supposed to be the best. I've got some sitting in my garage, haven't had good enough weather to try it out yet. 

Share this post


Link to post
Share on other sites

Decided to drain my catch can while it was nice out. Figured while it was up in the air, I would do an oil change. While it was draining oil, did a quick clean on the engine bay. Then figured I'd check the cabin air filter & it was disgusting as well, so it was replaced too. 

20200419_161840.jpg

  • Like 2

Share this post


Link to post
Share on other sites

Havent updated the forums in a while, a lot of the same people are in the facebook group. But here goes.

 

List of mods:
 
Physical
Swapped puddle lights for blue LEDs
Swapped turn signals for switchback LEDs
Changed license plate lights to LEDs
Grill swap
Wrap headlights in hex pattern tint
Blackout side window trim
Blackout gray/silver bumper pieces
Black out silver door handle trim
Door edge protectors
Tinted front windows
Weathertech in-channel window deflectors
Underhood LED lighting
Ford door jam plates
 
Forscan
Secure idle (police mode) already enabled from factory
Double honk disabled
Door ajar chime disabled
Update Sync3 theme to GT Performance theme (with GT Performance splash screen)
Added heated/cooled seat buttons to screen
Changed door ajar light
Set fog lights to stay on when high beams are on (Bambi mode)
Changed turn signal tap from 3 to 6
 
In Progress
Wrap taillights in hex pattern tint
Blackout rims (next)
Exhaust tips (blacked out or body color, haven't decided yet)
Wheel well lighting (subtle, dont worry it'll look good)
Grill backlighting
Wireless 4 channel control module (for all the lighting)
 
Planned
Custom sequential tails (brake and turns)
Custom sequential signal/DRLs (front)
Angel and Demon Eyes (eventually)
Lowering kit
Hood deflector (when i find one i really like)
 
Trying to link or embed a clip of my switchbacks working. May take a couple tries tho.
 

20200414_141457.jpg

94147767_10107620827582360_510487035274854400_n.jpg

Edited by soUNTOUCHABLE
Trying to get switchback clip to work
  • Like 2

Share this post


Link to post
Share on other sites
32 minutes ago, Gadgetjq said:

That's one heck of a list!  I bow to you sir! bow.gif.4c6bc4ad6560e10d608ad44003dba0c6.gif

 

Ha, you made a large part of it possible with your excellent info and your gadget page. I really appreciate you bro.

Share this post


Link to post
Share on other sites

Not everyone’s cup of tea, but the wife wanted a subtle “FORD PERFORMANCE” decal somewhere on the exterior of her new ST. We decided on this location. 

EEDB9732-4EBE-4588-AD3F-DC77EB0F3978.jpeg

4BE9E780-7AE5-49DE-9E87-1542E89960A3.jpeg

FC12226B-42B7-46AB-8D9D-75A2E0F572D8.jpeg

  • Like 2

Share this post


Link to post
Share on other sites

Sorry, accidental double post. Mods can delete this reply

Edited by Lunar_ST

Share this post


Link to post
Share on other sites

Another small cosmetic mod this week. “ST” wheel center caps. 

59B85289-EC93-434C-9FBF-CB22985604AD.jpeg

  • Like 3
  • Haha 1

Share this post


Link to post
Share on other sites

Something you can actually see without being eight feet tall or in an airplane.  LOL

Share this post


Link to post
Share on other sites
6 hours ago, Lunar_ST said:

Another small cosmetic mod this week. “ST” wheel center caps. 

 

Where you able to remove the old ones without taking the wheels off? If so how?

Share this post


Link to post
Share on other sites
4 hours ago, omar302 said:

 

Where you able to remove the old ones without taking the wheels off? If so how?


Yes, I’ve never removed a wheel to get these off.  A small flat head wedged in will pop them right out on most cars. 

Edited by Lunar_ST
  • Like 1

Share this post


Link to post
Share on other sites
On 4/28/2020 at 4:20 PM, dajo2012 said:

Something you can actually see without being eight feet tall or in an airplane.  LOL

Hahaha very true. That’s why it was a “subtle mod”....no one can see it, just wanted to bring some red element to the roof. We also live in a very hilly area where roof of vehicles are easily seen by other vehicles, and my wife works downtown where hi-rise buildings look down on vehicles all day. 

Edited by Lunar_ST

Share this post


Link to post
Share on other sites

I changed the PTU fluid again to Redline shockproof, clean and clear drain, but feel better. Still clunks on tip in, but abused  on a Procharged Nissan Z. Really good view in the rear view mirror. Sweet cars. 

  • Like 1

Share this post


Link to post
Share on other sites

Ordered new B&I 18 PC. Real carbon fiber dash kit today for my 2019 SEL was $65 additional for said real CF from Carid,did a lot of research and buying individual pieces was way more expensive and color and patterns would defiantly be different.anyone have insight/tips on install

  • Like 1

Share this post


Link to post
Share on other sites

Added a battery charger quick connect.  It eliminates alligator clips, sparks and other nuisances associated with bringing your Edge battery up to a full charge.  Full details here:

 

  • Like 1

Share this post


Link to post
Share on other sites
On 5/4/2020 at 5:08 PM, Gadgetjq said:

Added a battery charger quick connect.  It eliminates alligator clips, sparks and other nuisances associated with bringing your Edge battery up to a full charge.  Full details here:

 

 

I like this idea, may do this myself too. Ive drained my battery twice in the last couple months just from working on different things and lights being left on. Definitely easier than jumping it all the time!

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×