Jump to content

Custom Search

Welcome to the Ford Edge Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford Edge Forum - the largest Ford Edge forum discussion board on the web. You must register to create new topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Benefits of membership:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .and more!
Click here to signup now
 
Guest Message by DevFuse

The official Ford authorized Ford Edge Registry is now live. More here!


Photo
* * * * * 3 votes

What have you done to/with your Edge/MKX today?


  • Please log in to reply
1237 replies to this topic

#1221 OFFLINE   nittanydoug

nittanydoug

    New Edge Member

  • Edge Member
  • 34 posts
  • Region:U.S. Great Lakes
  • Location:Michigan
  • Edge's Year:2014

Posted 21 October 2017 - 09:03 PM

Finished installing hid's from Dan and some knock off led puddle lamps. Guess I need to see it next week when I'm driving in the dark to confirm better lighting with the hid's







Lose this advertisement by becoming a member. Click here to create a free account.


#1222 OFFLINE   chefduane

chefduane

    Ford Edge Enthusiast

  • Edge Platinum Member
  • 545 posts
  • Region:U.S. Southern Plains
  • Location:Dallas, TX
  • Edge's Year:2011

Posted 21 October 2017 - 11:56 PM

Changed oil and filter.  Mobil-1 5w20 and a K&N Performance filter.  I usually go with a M-1 filter but I liked the idea of the 1" wrench off design.  Easy on, easy off.

Also cleaned the AEM DryFlo air filter.  MAKE SURE IT DRIES WELL BEFORE RE-INSTALLING IT!!


  • WWWPerfA_ZN0W likes this

#1223 OFFLINE   Nick Halstead

Nick Halstead

    Ford Edge Enthusiast

  • Facebook Member
  • 967 posts
  • Region:U.S. Pacific Coast
  • Location:Hawaii
  • Edge's Year:2015

Posted 22 October 2017 - 03:48 AM

Well mines at shop for 2 time in 4 months getting leak fixed between engine/transmission
  • WWWPerfA_ZN0W likes this

#1224 OFFLINE   WWWPerfA_ZN0W

WWWPerfA_ZN0W

    Ford Edge Legal Resident

  • Edge Platinum Member
  • 8,217 posts
  • Region:U.S. Northeast
  • Location:Maryland
  • Edge's Year:Decline

Posted 22 October 2017 - 09:50 AM

That sucks, Nick!  Can't they figure out the problem, or are just doing a poor job fixing it, something simple maybe like not letting sealants cure long enough?



#1225 OFFLINE   enigma-2

enigma-2

    Ford Edge Fanatic

  • Edge Member
  • 2,505 posts
  • Region:U.S. Great Lakes
  • Location:Indiana
  • Edge's Year:2009

Posted 22 October 2017 - 03:41 PM

Well mines at shop for 2 time in 4 months getting leak fixed between engine/transmission

Bummer. I read some time ago in the Explorer forum of a felow having the same thing. Answer was if the fluid was red it was atf if brown it was oil. (Rear seal leaking). They felt it was impossible to determine without separating the engine from the transmission.

Hope they are able to find it. You get a loaner?
  • WWWPerfA_ZN0W likes this

#1226 OFFLINE   nittanydoug

nittanydoug

    New Edge Member

  • Edge Member
  • 34 posts
  • Region:U.S. Great Lakes
  • Location:Michigan
  • Edge's Year:2014

Posted 22 October 2017 - 05:57 PM

Ordered some 17" steel wheels and snow tires today. For the price difference I can buy a few different wheel covers to make it thru the winter.
  • WWWPerfA_ZN0W likes this

#1227 OFFLINE   Spree

Spree

    New Edge Member

  • Edge Member
  • 78 posts
  • Region:Decline
  • Location:Indiana
  • Edge's Year:2013

Posted 10 November 2017 - 01:22 AM

2013 MKX, When I remote start me ride....what turns on the side mirrors to defrost? Everything seems to turn on except the mirrors. maybe I don't have something set right.  



#1228 OFFLINE   omar302

omar302

    Ford Edge Addict

  • Edge Platinum Member
  • 1,668 posts
  • Region:Middle East
  • Location:Qatar
  • Edge's Year:2011

Posted 10 November 2017 - 04:19 AM

Does the rear defrost turn on? The mirror heaters are tied to the rear defrost.

What might be the issue is that the mirror heaters don't get power with remote start.
  • WWWPerfA_ZN0W likes this

#1229 OFFLINE   rvcjew

rvcjew

    New Edge Member

  • Edge Member
  • 79 posts
  • Region:U.S. Pacific Coast
  • Location:USA,CA
  • Edge's Year:2016

Posted 11 November 2017 - 06:47 AM

Well coolant was majorly low I noticed today on a maintenance check for the trip down to San Diego. Lasted 25k without needing filling so not bad, also been carrying lots of wood lately (can confirm it will hold a 4x8 above you but you better duck down) and had some windshield damage filled (semi threw a rock going the other way what are the odds) and have yet to paint the gouge in the hood  :(. I think the windshield would have been a loss if it did not hit the hood first. At least the Hood Protector is pitted and not my hood front so something went good this month.

 

mC7tMAcl.jpg

0twnZ2ml.jpg

98a0EU6l.jpg


  • WWWPerfA_ZN0W likes this

#1230 OFFLINE   Spree

Spree

    New Edge Member

  • Edge Member
  • 78 posts
  • Region:Decline
  • Location:Indiana
  • Edge's Year:2013

Posted 11 November 2017 - 09:33 PM

Does the rear defrost turn on? The mirror heaters are tied to the rear defrost.

What might be the issue is that the mirror heaters don't get power with remote start.

The defrost does turn on. I was just wondering if I could set something so the mirrors defrost with remote start? 


  • WWWPerfA_ZN0W likes this

#1231 OFFLINE   omar302

omar302

    Ford Edge Addict

  • Edge Platinum Member
  • 1,668 posts
  • Region:Middle East
  • Location:Qatar
  • Edge's Year:2011

Posted 11 November 2017 - 10:43 PM

There is no separate setting for the heated mirrors. At least none that I know of.


  • WWWPerfA_ZN0W likes this

#1232 OFFLINE   chefduane

chefduane

    Ford Edge Enthusiast

  • Edge Platinum Member
  • 545 posts
  • Region:U.S. Southern Plains
  • Location:Dallas, TX
  • Edge's Year:2011

Posted 12 November 2017 - 12:54 AM

Shouldn't everything that you had turned on before you shut the ignition off come back on when you start the car.  IE: turn the heated mirrors on before you shut down and they come on at next start up.  Maybe I am missing something but I thought that's how remote start works.  I've never really checked if the side mirror heaters come on.  This is Texas, don't really need them.


  • WWWPerfA_ZN0W likes this

#1233 OFFLINE   WWWPerfA_ZN0W

WWWPerfA_ZN0W

    Ford Edge Legal Resident

  • Edge Platinum Member
  • 8,217 posts
  • Region:U.S. Northeast
  • Location:Maryland
  • Edge's Year:Decline

Posted 12 November 2017 - 06:37 AM

That's a lotta hurt to take!  How low WAS the coolant?  Keep an eye on it, it should drop pretty slowly over time after the refill.

Well coolant was majorly low I noticed today on a maintenance check for the trip down to San Diego. Lasted 25k without needing filling so not bad, also been carrying lots of wood lately (can confirm it will hold a 4x8 above you but you better duck down) and had some windshield damage filled (semi threw a rock going the other way what are the odds) and have yet to paint the gouge in the hood  :(. I think the windshield would have been a loss if it did not hit the hood first. At least the Hood Protector is pitted and not my hood front so something went good this month.



#1234 OFFLINE   omar302

omar302

    Ford Edge Addict

  • Edge Platinum Member
  • 1,668 posts
  • Region:Middle East
  • Location:Qatar
  • Edge's Year:2011

Posted 12 November 2017 - 11:53 AM

Shouldn't everything that you had turned on before you shut the ignition off come back on when you start the car.  IE: turn the heated mirrors on before you shut down and they come on at next start up.  Maybe I am missing something but I thought that's how remote start works.  I've never really checked if the side mirror heaters come on.  This is Texas, don't really need them.


Rear defrost (with the heated mirrors) & heated/cooled seats always default to off after turning off the ignition.
  • WWWPerfA_ZN0W likes this

#1235 OFFLINE   Nick Halstead

Nick Halstead

    Ford Edge Enthusiast

  • Facebook Member
  • 967 posts
  • Region:U.S. Pacific Coast
  • Location:Hawaii
  • Edge's Year:2015

Posted 14 November 2017 - 01:08 AM

removed the active shutter grill system

23472856_10212647961047348_2568000029224


Edited by Nick Halstead, 14 November 2017 - 01:15 AM.

  • WWWPerfA_ZN0W and Xtra like this

#1236 OFFLINE   rvcjew

rvcjew

    New Edge Member

  • Edge Member
  • 79 posts
  • Region:U.S. Pacific Coast
  • Location:USA,CA
  • Edge's Year:2016

Posted 14 November 2017 - 03:02 AM

Wow, didn't know our window wash tank was that big!

#1237 OFFLINE   candurin

candurin

    Ford Edge Enthusiast

  • Edge Member
  • 1,025 posts
  • Region:Decline
  • Location:Southern NJ

Posted 14 November 2017 - 07:39 AM

And yet, in the winter I need to refill it weekly (if not daily).
  • WWWPerfA_ZN0W likes this

#1238 OFFLINE   candurin

candurin

    Ford Edge Enthusiast

  • Edge Member
  • 1,025 posts
  • Region:Decline
  • Location:Southern NJ

Posted 14 November 2017 - 07:39 AM

Ugh... double post.

Edited by candurin, 14 November 2017 - 07:41 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users